cblack added a comment.
Splitting into multiple classes seems like a good idea, but "strategy"? Seems like an odd choice of name to me. INLINE COMMENTS > iconitem.cpp:58 > + > +class NullStategy : public IconItemStrategy > +{ Is this class necessary? I feel like this class's behaviour should be what its parent does without a child implementation. > iconitem.cpp:58 > + > +class NullStategy : public IconItemStrategy > +{ Also, "Stategy" instead of "Strategy" > iconitem.cpp:80 > +private: > + QIcon m_icon; > +}; Seems unused. REPOSITORY R242 Plasma Framework (Library) REVISION DETAIL https://phabricator.kde.org/D28470 To: kmaterka, #plasma, broulik, apol, davidedmundson Cc: cblack, kde-frameworks-devel, #plasma, LeGast00n, GB_2, michaelh, ngraham, bruns