[ 
https://issues.apache.org/jira/browse/FLINK-18808?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17176833#comment-17176833
 ] 

Piotr Nowojski commented on FLINK-18808:
----------------------------------------

{quote}
At present, a record may be broadcast to multiple downstreams. If numRecordsOut 
is added to RecordWriter, this will become the actual number of records sent.
{quote}
It depends where and how would you increment the counter [~Ming Li]. In an 
essence, there are 3 relevant entry points to this class:
{code}
        /**
         * This is used to send regular records.
         */
        public abstract void emit(T record) throws IOException, 
InterruptedException;

        /**
         * This is used to send LatencyMarks to a random target channel.
         */
        public abstract void randomEmit(T record) throws IOException, 
InterruptedException;

        /**
         * This is used to broadcast streaming Watermarks in-band with records.
         */
        public abstract void broadcastEmit(T record) throws IOException, 
InterruptedException;
{code}
and each one of them is invoked once per record. There are two implementations 
of this class, and it's a bit hard to follow the call chains, but take a look 
at where {{serializer.serializeRecord(...)}} is called. Each record is also 
serialised once, so if you would count those calls 
({{serializer.serializeRecord(...)}}), that would give you {{numRecordsOut}}, 
as number of records produced. If you would count all of the invocations to 
{{RecordWriter#emit/randomEmit/broadcastEmit()}}, it would give you the same 
number, but that's 6 places (for two implementations of {{RecordWriter}}).

> Task-level numRecordsOut metric may be underestimated
> -----------------------------------------------------
>
>                 Key: FLINK-18808
>                 URL: https://issues.apache.org/jira/browse/FLINK-18808
>             Project: Flink
>          Issue Type: Improvement
>          Components: Runtime / Metrics, Runtime / Task
>    Affects Versions: 1.11.1
>            Reporter: ming li
>            Assignee: ming li
>            Priority: Major
>              Labels: pull-request-available, usability
>         Attachments: image-2020-08-04-11-28-13-800.png, 
> image-2020-08-04-11-32-20-678.png
>
>
> At present, we only register task-level numRecordsOut metric by reusing 
> operator output record counter at the end of OperatorChain.
> {code:java}
> if (config.isChainEnd()) {
>    operatorMetricGroup.getIOMetricGroup().reuseOutputMetricsForTask();
> }
> {code}
> If we only send data out through the last operator of OperatorChain, there is 
> no problem with this statistics. But consider the following scenario:
> !image-2020-08-04-11-28-13-800.png|width=507,height=174!
> In this JobGraph, we not only send data in the last operator, but also send 
> data in the middle operator of OperatorChain (the map operator just returns 
> the original value directly). Below is one of our test topology, we can see 
> that the statistics actually only have half of the total data received by the 
> downstream.
> !image-2020-08-04-11-32-20-678.png|width=648,height=251!
> I think the data sent out by the intermediate operator should also be counted 
> into the numRecordsOut of the Task. But currently we are not reusing 
> operators output record counters in the intermediate operators, which leads 
> to our task-level numRecordsOut metric is underestimated (although this has 
> no effect on the actual operation of the job, it may affect our monitoring).
> A simple idea of ​​mine is to modify the condition of reusing operators 
> output record counter:
> {code:java}
> if (!config.getNonChainedOutputs(getUserCodeClassloader()).isEmpty()) {
>    operatorMetricGroup.getIOMetricGroup().reuseOutputMetricsForTask();
> }{code}
> In addition, I have another question: If a record is broadcast to all 
> downstream, should the numRecordsOut counter increase by one or the 
> downstream number? It seems that currently we are adding one to calculate the 
> numRecordsOut metric.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Reply via email to