[
https://issues.apache.org/jira/browse/SANDBOX-487?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14264057#comment-14264057
]
Bruno P. Kinoshita commented on SANDBOX-487:
--------------------------------------------
+1 for your API change Benedikt. I think I even added a comment in the Name or
HumanNameParserParser that it was not thread-safe, though I tried to simply
mimic the behaviour of the PHP library.
What about changing the name of {{HumanNameParserParser}} to
{{HumanNameParser}} too. That bugged me, but then I realized that it is the
composition of {{<project_name>Parser}}. Since we are porting it to \[text\], I
think we can drop that for a simpler name.
> Maybe {{getNicknames()}} should even return a {{List<String>}} ?!
Not sure why the property was named {{nicknames}} rather than {{nicknames}}.
Maybe it was a typo in the PHP library?
There is one method that I didn't implement, that was {{getArray()}}. [The
method|(https://github.com/jasonpriem/HumanNameParser.php/blob/52b72770f88a751367e21cbf60bf8ab0359c3cf0/Parser.php#L97]
simply returned a PHP associative array with all the values (think of it as a
java.util.Map with the variable name -> variable value). But I don't think we
need that.
> Human name parser
> -----------------
>
> Key: SANDBOX-487
> URL: https://issues.apache.org/jira/browse/SANDBOX-487
> Project: Commons Sandbox
> Issue Type: Improvement
> Components: Commons Text
> Reporter: Bruno P. Kinoshita
> Priority: Minor
> Labels: name, parser, text
>
> The project
> [HumanNameParser.java|http://tupilabs.github.io/HumanNameParser.java/] is a
> port to Java of the
> [HumanNameParser.php|http://jasonpriem.org/human-name-parse/], both licensed
> under the MIT License.
> This issue was created to discuss a similar parser, based on the Java
> version, to the [text] component.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)