Hi Christoph and all, On Fri, Aug 5, 2016 at 6:17 PM, Christoph Becker <cmbecke...@gmx.de> wrote: > > I think the names are okay, but it should be pointed out that they are > not related to assert() (particularly, that they are not affected by the > assert.* ini directives). Maybe "assume" or "require" instead of > "assert" would therefore be better in this regard.
Good suggestion! Users may confuse with assert() and filter_assert()... I don't mind changing function names at all. "assume" sounds to weak for me. "require" sounds better to me. assert_require_*() may be the best choice among - validate_*() - filter_assert_*() - filter_assume_*() - filter_require_*() Do you like/feel ok with filter_require_*()? If you have better suggestion, it is appreciated. If there isn't comment in a few days, I'll use filter_require_var() <- validate_var() filter_require_var_array() <- validate_var_array() filter_require_input() <- validate_input() filter_require_input_array() <- validate_input_array() Regards, -- Yasuo Ohgaki yohg...@ohgaki.net -- PHP Internals - PHP Runtime Development Mailing List To unsubscribe, visit: http://www.php.net/unsub.php