Dan,

That's a good question as well, with the current $var syntax I'm assuming NO.
You're using the $var3 name as a key, not as the $paramToOverride value.

Maybe the collon could be used here?

$paramToOverride = 'var3';
testFunction(:$paramToOverride => 'bar'); // Colon before $ would make
the key :var3 ?

Then again, I like the colon syntax instead of => to assign fn(key:
val) pairs for readability/clearer separation of array syntax, so that
would probably make:
testFunction(:$paramToOverride: 'bar');

As my suggestion and I'm not sure I like it... :x

-- 
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to