Hi!

I'm sure you understand that nesting makes things much more easier to read.
fpm.workers.<pool name ASCII only and no spaces>.pm.dynamic.start_servers is 
not my preferred syntax.

This is actually highly debatable. Nesting does not allow you an easy way to know where each value belongs to - you'd have to climb up the tree and hope you didn't skip some branch by chance. Of course, it is much more verbose, but you don't really need that many levels of hierarchy. If you give up on literally translating xml, I'm sure you'll notice that start_servers can live on it's own without being prefixed, etc. So you'd have one level for FPM in general, one for specific worker, one for category and one for actual option:

fpm.myworker.server.start_servers = 20
fpm.myworker.php_defines.memory_limit = 64M

etc. It's not that bad.

As for spaces in pool names - come on, you're not going to write a novel there. No programming language allows spaces in identifiers and we manage to live with it :)

And yes, this is how it should look like since you're implying that FPM config
should be a part of php.ini (otherwise I don't see how these two different 
files are related at all).

It shouldn't be part of php.ini, but it'd be nice if it was part of php config system.
--
Stanislav Malyshev, Zend Software Architect
s...@zend.com   http://www.zend.com/
(408)253-8829   MSN: s...@zend.com

--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to