--- Greg Beaver <[EMAIL PROTECTED]> wrote:
> Marcus Boerger wrote:
> > Hello internals,
> > 
> >   i'd like to add two array functions:
> > 
> > - bool array_has_more(array $array)
> 
> I don't like "array_has_more"
> 
> array_at_end()
> 
> would work better for me since the function that makes it evaluate as
> true is:
> 
> end($array);


Hi and please pardon my intrusion to your discussion. Aren't the semantics of
functions of this sort usually named is_* in PHP? I would suggest something
such as is_last(). I suppose too that objects that implement the appropriate
iteration interfaces could use this? If so, would using "array" for naming
purposes make things less clear? To me, none of the existing array_* functions
have an "if" semanatic and I think that is a good thing.

Thanks.
boots

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 

-- 
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to