Hello boots, there are two rules that could be applied. First is the extension name followed by underscore followed by functional name. Second is "is_" followed by type condition. The important thing here is that the latter rule so far has been mainly used for type checks. And in this case we are not checking for a type.
best regards marcus Sunday, May 28, 2006, 9:00:56 AM, you wrote: > --- Greg Beaver <[EMAIL PROTECTED]> wrote: >> Marcus Boerger wrote: >> > Hello internals, >> > >> > i'd like to add two array functions: >> > >> > - bool array_has_more(array $array) >> >> I don't like "array_has_more" >> >> array_at_end() >> >> would work better for me since the function that makes it evaluate as >> true is: >> >> end($array); > Hi and please pardon my intrusion to your discussion. Aren't the semantics of > functions of this sort usually named is_* in PHP? I would suggest something > such as is_last(). I suppose too that objects that implement the appropriate > iteration interfaces could use this? If so, would using "array" for naming > purposes make things less clear? To me, none of the existing array_* functions > have an "if" semanatic and I think that is a good thing. > Thanks. > boots > __________________________________________________ > Do You Yahoo!? > Tired of spam? Yahoo! Mail has the best spam protection around > http://mail.yahoo.com Best regards, Marcus -- PHP Internals - PHP Runtime Development Mailing List To unsubscribe, visit: http://www.php.net/unsub.php