On Thu, 12 Dec 2019, Matt Roper <matthew.d.ro...@intel.com> wrote:
> On Fri, Nov 29, 2019 at 03:37:06PM +0200, Stanislav Lisovskiy wrote:
>>  struct skl_wm_level {
>> @@ -1215,6 +1210,8 @@ struct drm_i915_private {
>>              bool distrust_bios_wm;
>>      } wm;
>>  
>> +    u8 enabled_slices; /* GEN11 has configurable 2 slices */
>
> Intel hardware has long used the terms "slice" and "subslice" for the
> way EUs are grouped on the GT side.  Now that this is pulled out from
> the substructs that gave it additional context, I think we need to
> rename this to something like 'enabled_dbuf_slices' to avoid confusion
> with the more widespread meaning of the word 'slice.'  Same for
> intel_atomic_state farther up.

Agreed.

BR,
Jani.


-- 
Jani Nikula, Intel Open Source Graphics Center
_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx

Reply via email to