TransformOnRead TransformOnWrite ? MutateOnRead/Write ?
/max On Sep 28, 2010, at 15:28, Steve Ebersole wrote: > "access" does not capture the essence of what you are doing though which > is mutating values to and fro. > > On Tue, 2010-09-28 at 08:57 -0400, Chris Bredesen wrote: >> read + write = access >> >> @ColumnAccessExpression? >> >> On 09/28/2010 07:33 AM, Steve Ebersole wrote: >>> Really we went through the same discussion when developing the original >>> feature in terms of what to "call it" when discussing/documenting it. I >>> like the "read" and "write" aspects; its the general quality of applying >>> read/write thats tougher to term. >>> >>> Another option is @ColumnReadWrite. >>> >>> >>> On Tue, 2010-09-28 at 11:29 +0200, Emmanuel Bernard wrote: >>>> As of right now, yes. >>>> Trying to support it was not super trivial but I can give it a second >>>> round today. >>>> >>>> @ReadWriteWrapper would work. We don't use wrapper though in the doc for >>>> this feature but that can be changed. >>>> >>>> >>>> On 28 sept. 2010, at 05:54, Steve Ebersole wrote: >>>> >>>>> Is the 'forColumn' attribute required if a single column value? >>>>> >>>>> >>>>> On Mon, 2010-09-27 at 22:53 -0500, Steve Ebersole wrote: >>>>>> @Wrapper( >>>>>> forColumn="credit_card_num", >>>>>> read="decrypt(credit_card_num)", >>>>>> write="encrypt(?)" >>>>>> ) >>>>>> >>>>>> @ReadWrapper( forColumn="credit_card_num", >>>>>> expression="decrypt(credit_card_num)" ) >>>>>> @WriteWrapper( forColumn="credit_card_num", expression="encrypt(?)" ) >>>>>> >>>>>> >>>>>> >>>>>> On Tue, 2010-09-28 at 00:10 +0200, Emmanuel Bernard wrote: >>>>>>> Hey guys, >>>>>>> I've implemented >>>>>>> http://opensource.atlassian.com/projects/hibernate/browse/HHH-4510 and >>>>>>> committed it. It basically looks like that >>>>>>> >>>>>>> @Entity >>>>>>> class CreditCard { >>>>>>> @Column(name="credit_card_num") >>>>>>> @ReadWriteExpression( >>>>>>> forColumn="credit_card_num", >>>>>>> read="decrypt(credit_card_num)", >>>>>>> write="encrypt(?)") >>>>>>> public String getCreditCardNumber() { return creditCardNumber; } >>>>>>> public void setCreditCardNumber(String number) { >>>>>>> this.creditCardNumber = number; } >>>>>>> private String creditCardNumber; >>>>>>> } >>>>>>> >>>>>>> However, I am not super happy about @ReadWriteExpression as a name. >>>>>>> @ColumnReadWriteExpression is the most correct name but quite mouthful. >>>>>>> >>>>>>> Anybody gets a better idea? >>>>>>> >>>>>>> Emmanuel >>>>>>> >>>>>>> _______________________________________________ >>>>>>> hibernate-dev mailing list >>>>>>> hibernate-dev@lists.jboss.org >>>>>>> https://lists.jboss.org/mailman/listinfo/hibernate-dev >>>>>> >>>>> >>>>> -- >>>>> Steve Ebersole<st...@hibernate.org> >>>>> http://hibernate.org >>>>> >>>> >>> >> _______________________________________________ >> hibernate-dev mailing list >> hibernate-dev@lists.jboss.org >> https://lists.jboss.org/mailman/listinfo/hibernate-dev > > -- > Steve Ebersole <st...@hibernate.org> > http://hibernate.org > > _______________________________________________ > hibernate-dev mailing list > hibernate-dev@lists.jboss.org > https://lists.jboss.org/mailman/listinfo/hibernate-dev _______________________________________________ hibernate-dev mailing list hibernate-dev@lists.jboss.org https://lists.jboss.org/mailman/listinfo/hibernate-dev