Hi Przemek,
Ops, I forgot one thing: When testing hbrun on OSX,
I noticed that the color changed after exiting hbrun
(from my default green to lightgray).
I'm not sure if this is a problem or not (and I've seen
multiple fixes from you regarding this), but in any
case I report it.
Brgds,
Viktor
On 2008.08.09., at 16:27, Przemyslaw Czerpak wrote:
On Sat, 09 Aug 2008, Szakáts Viktor wrote:
Vi Viktor,
* bin/hb-mkslib.sh
! Changed the way harbour.dylib is created on Darwin systems
to support universal builds. Please review and test.
Thank you, I cannot test it but it looks correct. I'll ad only minor
cleanup.
! Fixed generating links for .dylibs on Darwin.
This is incorrect. You replaced relative soft links with
absolute ones and should be reverted.
! Removed one excessive 'cd "${OTMPDIR}"' command.
(I hope this is right)
It was minor protection against theoretically possible error in
mkdir/cd operations executed during .a files extracting.
! Removed previously added $(L_USR) from Darwin dynamic
lib creation command line, as the L_USR "-arch" flags
(and probably others) cannot work here.
; TOFIX: 'ld: library not found for -lharbour' is still
present.
It's possible that it cannot accept during linking harbour shared
library which is not located in one of system directories.
But 1-st I would like to see file list inside final .tgz archive.
I'll commit some modifications to hb-mkslib.sh in a while and
if possible please rebuild Harbour and send this list to me.
* include/hbsetup.h
+ Added autodetection for HB_OS_DARWIN (based on __APPLE__).
If possible please try to extend this condition adding some additional
macro like __unix__, f.e.:
#if defined(__APPLE__) && \
( defined(unix) || defined(__unix) || defined(__unix__) )
#define HB_OS_DARWIN
#endif
to avoid possible collision with some older MacOS versions.
* source/vm/runner.c
__HRBGETFU -> HB_HRBGETSYMBOL
This functions should be renamed to HB_HRBGETFUN[C[SYM]]()
and fixed to respect only functions. Now it can return memvar or alias
symbol if it exists with the same name as function in .hrb file.
__HRBDOFU -> HB_HRBDOSYMBOL
This functions is redundant and should be removed. It's subset of
DO() function functionality.
; NOTE: HB_DBG_*() function should I believe correctly
named as __DBG*(), as they are indeed internal
functions, not meant to guaranteed for final apps.
We should do this cleanup in the future.
No one should try to access debugger functions in normal code
because we do not guarantee that we will keep their functionality
in the future so they should rather use __DBG*() prefix anyhow
the debugger code is mostly developed by Phil Krylov in xHarbour
and such modification will make synchronization with xHarbour harder.
best regards,
Przemek
_______________________________________________
Harbour mailing list
Harbour@harbour-project.org
http://lists.harbour-project.org/mailman/listinfo/harbour