The core lib's name would naturally be hbzlib
(like hbpcre), but we already have hbzlib in
contrib, which collides with it.
So, I'd suggest to move strict zlib interface
functions (Harbour level ones that is) from
contrib/hbzlib to source/rtl, and rename the
remaining MiniZip stuff in contrib to hbmzip.
Opinions?
Hi,
sounds a little complicated, but I have nothing better to suggest.
Just a wish for the future, I'd like to have possibility to use
zlib1.lib (import library created from zlib1.dll) instead of hbzlib.lib.
The problem is we have to libraries:
1) zlib wrapper functions;
2) zlib itself.
Both of them ties for the same name hbzlib. The proposed solution is to
move zlib wrapper functions to hbmzip (together with minizip code).
Putting zlib wrapper function into hbzlib could seem more natural, but
this choice will not allow to use dynamic library.
The other strange thing is that we have zlib in the core code, but zlib
wrapper functions in contrib. I would suggest to let developers avoid
contrib and move zlib wrapper functions to the core also. Using the same
hbzlib library is a bad choice (see above). One more library for wrapper
functions is not nice solution also. We can create module containing
wrapper functions in rtl library.
Thus:
rtl.lib + hbzlib.lib = static linked zlib functionality
rtl.lib + zlib1.lib = dynamically linked zlib functionality
Best regards,
Mindaugas
_______________________________________________
Harbour mailing list
Harbour@harbour-project.org
http://lists.harbour-project.org/mailman/listinfo/harbour