Ludovic Courtès (2015-10-11 19:50 +0300) wrote: > Alex Kost <alez...@gmail.com> skribis: > >> +(define (sdl-union . sdl-packages) >> + "Return 'sdl-union' package that is the union of SDL-PACKAGES. >> +If SDL-PACKAGES are not specified, all SDL libraries are used." >> + (let* ((sdl-packages (if (null? sdl-packages) >> + (list sdl >> + sdl-gfx >> + sdl-image >> + sdl-mixer >> + sdl-net >> + sdl-ttf) >> + sdl-packages)) > > What about writing it like this: > > (define* (sdl-union #:optional (packages (list sdl sdl-gfx …))) > …) > > That would be more concise and more idiomatic. > > If that’s fine with you, OK to push with this change.
Sure, fixed and pushed, thanks ! -- Alex