Quoting Ludovic Courtès (2014-10-19 16:24:17)
> Ian Denhardt <i...@zenhack.net> skribis:
> 
> > How about this: separate it out into to functions: version-prefix, which
> > is the same as what I have now, but takes a (mandatory) argument
> > specifying the number of fields, and feature-version, which is defined
> > like:
> >
> >     (define (feature-version version) (version-prefix version 2))
> >
> > ..with an appropriate docstring explaining the use case. Thoughts?
> 
> Sounds good to me, although I’d rather call ‘feature-version’, say,
> ‘version-major+minor’, on the grounds that the semantics of version
> numbers are specific to each project.  Mark?

Sounds good to me; I'll update the patch soon.

-Ian

Attachment: signature.asc
Description: signature

Reply via email to