Mark H Weaver <m...@netris.org> writes: > I agree that the names are uncomfortably long. We could shorten them > without much loss of clarity by replacing "lisp_nil" with "nil" and > "and_not" with "not", yielding: > > scm_is_false_assume_not_nil scm_is_true_assume_not_nil > scm_is_false_not_nil scm_is_true_or_nil > scm_is_false_or_nil scm_is_true_not_nil > > scm_is_lisp_false scm_is_lisp_true > > scm_is_null_assume_not_nil > scm_is_null_not_nil > scm_is_null_or_nil > > scm_is_bool_not_nil > scm_is_bool_or_nil > > I can still do this if y'all would prefer the shorter names.
FWIW, dropping "lisp_" looks OK, but I'm not sure about dropping "and_". "scm_is_false_not_nil" feels notably harder to understand than "scm_is_false_and_not_nil". > Are there any remaining objections to mapping scm_is_false/true/null > as follows? > > scm_is_null --> scm_is_null_or_lisp_nil > scm_is_false --> scm_is_false_or_lisp_nil > scm_is_true --> scm_is_true_and_not_lisp_nil (Not from me - but I assume you're checking with others...) Neil