On Wed, Jun 21, 2023 at 03:14:13PM +0200, Julian Andres Klode wrote: > This is version 2 of the patch series, addressing the > review from v1a. > > It's split in two batches to first change the sdl code > to match the coding style and then introduce the sdl2 > support in the correct style, to avoid having unrelated > style changes in the latter patch making it harder to read. > > I have not addressed the SDL2_LIBS vs LIBSDL2 controversy > in the code: > > On Wed, Jun 21, 2023 at 02:24:56PM +0200, Daniel Kiper wrote: > > On Fri, Jun 16, 2023 at 01:52:27PM +0200, Julian Andres Klode wrote: > > > diff --git a/grub-core/Makefile.core.def > > > b/grub-core/Makefile.core.def > > > index e458aa665..d2cf29584 100644 > > > --- a/grub-core/Makefile.core.def > > > +++ b/grub-core/Makefile.core.def > > > @@ -418,7 +418,7 @@ program = { > > > > > > ldadd = 'kernel.exec$(EXEEXT)'; > > > ldadd = '$(MODULE_FILES)'; > > > - ldadd = 'lib/gnulib/libgnu.a $(LIBINTL) $(LIBUTIL) $(LIBSDL) > > > $(LIBUSB) $(LIBPCIACCESS) $(LIBDEVMAPPER) $(LIBZFS) $(LIBNVPAIR) > > > $(LIBGEOM)'; > > > + ldadd = 'lib/gnulib/libgnu.a $(LIBINTL) $(LIBUTIL) $(LIBSDL) > > > $(SDL2_LIBS) $(LIBUSB) $(LIBPCIACCESS) $(LIBDEVMAPPER) $(LIBZFS) > > > $(LIBNVPAIR) $(LIBGEOM)'; > > > > s/SDL2_LIBS/LIBSDL2/? If possible stick to the naming convention here. > > The libs expand from pkg-config call, compare FUSE_LIBS, there's also > SDL2_CPPFLAGS and so on or something. I don't think adding a 2nd > variable with the same content adds value.
This is what I expected to some extent. So, leave it as is... For all patches Reviewed-by: Daniel Kiper <daniel.ki...@oracle.com>... Thank you for adding SDL2 support! Daniel _______________________________________________ Grub-devel mailing list Grub-devel@gnu.org https://lists.gnu.org/mailman/listinfo/grub-devel