David Kastrup <d...@gnu.org> writes:

> Junio C Hamano <gits...@pobox.com> writes:
>
>> Michael Haggerty <mhag...@alum.mit.edu> writes:
>>
>>>     while (*path) {
>>> -           const char *slash;
>>>             struct cache_tree_sub *sub;
>>> +           const char *slash = strchr(path, '/');
>>>  
>>> -           slash = strchr(path, '/');
>>>             if (!slash)
>>>                     slash = path + strlen(path);
>>
>> Isn't the above a strchrnul()?
>
> Yes.  I realized that previously, but since it's a GNU extension rather
> than part of the C standards, I discarded that idea.  Calling
>
>     git grep strchrnul
>
> shows, however, that it _is_ used plentifully already.

Yes, we have a fallback definition in compat-util, I think.

> Still worth thinking about whether there is no better name than slash
> for something that indicated the end of the current path name segment.

end_of_path_component?  Sounds a bit too long ;-)
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to