Attention is currently required from: dexter, laforge.

neels has posted comments on this change by neels. ( 
https://gerrit.osmocom.org/c/pysim/+/41845?usp=email )

Change subject: personalization: add param_source.py, add batch.py
......................................................................


Patch Set 7:

(12 comments)

File pySim/esim/saip/batch.py:

https://gerrit.osmocom.org/c/pysim/+/41845/comment/87b50309_cca942f4?usp=email :
PS6, Line 65:                  params: list[ParamAndSrc]=None,
> IIRC the linter warns against passing empty lists as default argument, 
> because in python there can a […]
Done


https://gerrit.osmocom.org/c/pysim/+/41845/comment/a1278baf_7973bef3?usp=email :
PS6, Line 92:                 csv_columns = next(self.csv_rows)
> hm that's right, it has to be an iter(list), thx
Done


https://gerrit.osmocom.org/c/pysim/+/41845/comment/ee3801c0_43243e2f?usp=email :
PS6, Line 97:             csv_row = None
> it is optional, configured by the caller, whether a CSV file is present. […]
Done


File pySim/esim/saip/param_source.py:

https://gerrit.osmocom.org/c/pysim/+/41845/comment/097eacb1_97e92446?usp=email :
PS6, Line 31: class ParamSource:
> That is right. […]
Done


https://gerrit.osmocom.org/c/pysim/+/41845/comment/0b078810_199635ae?usp=email :
PS6, Line 42:            so the user can enter '0000' to get a four digit 
random number."""
> Hmm. it's even worse, most subclasses completely replace this. I will make a 
> better plan, thanks.
Done


https://gerrit.osmocom.org/c/pysim/+/41845/comment/87a9f9be_2aa2726c?usp=email :
PS6, Line 51:
> yea you're right, sometimes i do sometimes i don't, thx. […]
Done


https://gerrit.osmocom.org/c/pysim/+/41845/comment/5d7a009c_99dc6ec7?usp=email :
PS6, Line 65:     def __init__(self, num_digits, first_value, last_value):
> Maybe add type annotations and agree on one distinct type? At the moment this 
> function can accepts a […]
Done


https://gerrit.osmocom.org/c/pysim/+/41845/comment/92b2f56b_245598a9?usp=email :
PS6, Line 80:
> If this is a private/internal method, I would mark it with double underscore 
> or single underscore?
not intended, in particular, to be internal


https://gerrit.osmocom.org/c/pysim/+/41845/comment/ba0fa97e_5d986644?usp=email :
PS6, Line 95:         last_value = int(last_str) if last_str is not None else 
"9" * len(first_str)
> heh funny code =) you are right
Done


https://gerrit.osmocom.org/c/pysim/+/41845/comment/691ffc9a_b4ce4220?usp=email :
PS6, Line 121:         val = random.randbytes(self.num_digits // 2) # TODO 
secure random source?
> This uses the fact that all BinaryParameter can take a bytes as input value. 
> […]
Done


https://gerrit.osmocom.org/c/pysim/+/41845/comment/c9bf8e23_3f3f390f?usp=email :
PS6, Line 149:         if val > self.val_first_last[1]:
> self.last_value would be easier to read.
Done


https://gerrit.osmocom.org/c/pysim/+/41845/comment/2c36f403_8e1416cd?usp=email :
PS6, Line 174:         return val
> it's more like […]
Done



--
To view, visit https://gerrit.osmocom.org/c/pysim/+/41845?usp=email
To unsubscribe, or for help writing mail filters, visit 
https://gerrit.osmocom.org/settings?usp=email

Gerrit-MessageType: comment
Gerrit-Project: pysim
Gerrit-Branch: master
Gerrit-Change-Id: I01ae40a06605eb205bfb409189fcd2b3a128855a
Gerrit-Change-Number: 41845
Gerrit-PatchSet: 7
Gerrit-Owner: neels <[email protected]>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: laforge <[email protected]>
Gerrit-CC: dexter <[email protected]>
Gerrit-Attention: laforge <[email protected]>
Gerrit-Attention: dexter <[email protected]>
Gerrit-Comment-Date: Sun, 15 Mar 2026 22:46:47 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: neels <[email protected]>
Comment-In-Reply-To: dexter <[email protected]>

Reply via email to