On 21:03 Fri 16 Jan , Peter Alfredsen wrote: > NO_MONO_DEPEND=( > "dev-lang/mono" > "dev-dotnet/libgdiplus" > "dev-dotnet/gluezilla" > )
I'm not a huge fan of having package-specific logic in eclasses. This would be nicer to see as a variable set in the packages like MONO_DEPEND="no". That would also get rid of the double-negative logic below: > if ! has "${CATEGORY}/${PN}" "${no_mono_depe...@]}" > then > RDEPEND="=dev-lang/mono-${GO_MONO_REL_PV}*" > DEPEND="${RDEPEND}" > fi > if [[ "${PV%_rc*}" != "${PV}" ]] > then > GO_MONO_P="${P%_rc*}" > SRC_URI="${PRE_URI}/${PN}/${GO_MONO_P} -> ${P}.tar.bz2" > S="${WORKDIR}/${GO_MONO_P}" > elif [[ "${PV%_pre*}" != "${PV}" ]] > then > GO_MONO_P="${P%_pre*}" > SRC_URI="${PRE_URI}/${PN}/${GO_MONO_P} -> ${P}.tar.bz2" > S="${WORKDIR}/${GO_MONO_P}" > else > GO_MONO_P=${P} > SRC_URI="http://ftp.novell.com/pub/mono/sources/${PN}/${P}.tar.bz2" > fi How about GO_MONO_P=${P%_[a-z]*} -- doesn't that work in all cases? -- Thanks, Donnie Donnie Berkholz Developer, Gentoo Linux Blog: http://dberkholz.wordpress.com
pgpCXilkgHzf0.pgp
Description: PGP signature