On Thu, Jun 28, 2012 at 3:08 PM, Rick C. Hodgin <foxmuldrs...@yahoo.com> wrote:
> How would you handle:
>
> isSystemClosed = true;

A good clean error message is ideal, and should be easy.   (A proxy
object such as inv_bool can do this easily enough, but it's still
going to hurt readability.)

> You're getting into nasty looking/non-obvious code to use language-existing 
> features for an ability that 1) is fundamental to software and 2) should have 
> native support without kludges.

No, the ability to have two different variables with different
semantics but shared backing store is not fundamental, it's rather a
violation of the law of least surprise.

(I'm not buying that lambdas are "nasty looking" or "non-obvious" for
C++ users.  They're a fundamental part of the language.)

I understand that you really like your notation, and think that it's a
clear win.  I don't think you'll have luck persuading compiler writers
or language committees, but maybe you'll prove me wrong.

-- James

Reply via email to