On Fri, Apr 4, 2008 at 10:58 AM, Chris Lattner <[EMAIL PROTECTED]> wrote: > > > On Apr 4, 2008, at 10:13 AM, H.J. Lu wrote: > > > > Hi, > > > > For each new set of x86 intrinsics, we introduce a new header file. It > > will be desirable for users just to include one header file for all > > intrinsics, current and future. Icc has <ia32intrin.h>, which includes > > proper individual intrinsic header files and users just need > > to include <ia32intrin.h> to get access to all intrinsics. > > > > We will implement meta intrinsic header file for AVX intrinsics. > > However, I am not sure if <ia32intrin.h> is the best name for it. > > Does anyone have any suggestions, how about <x86intrin.h>? > > > > I prefer <x86intrin.h>, as these are presumably usable in x86-64 mode. > > One random request: would it be possible to keep mm_malloc.h out of the > umbrella header? Inclusion of mm_malloc.h make use of SSE difficult in > kernel contexts, as mm_malloc.h pulls in stdlib.h and errno.h. >
The idea is one header file to make all intrinsics available, including _mm_malloc () and _mm_free (). Unless we exclude those 2, I don't see that we have a choice. H.J.