It had been a while, so this merge was fairly long. It exposed a bug in complex lowering (we were not splitting the basic block properly when expanding complex divisions) and the ppc back end still hadn't been updated for the new walk_gimple_stmt interface.
I also changed all the gimple_locus() and related functions to use 'location' instead of 'locus'. Tom Tromey's location_t patch is now in the branch so we don't have to deal with the ugly #ifdefs. The function gimple_locus_empty_p was mostly used with a ! in front, so I changed it to gimple_has_location to make predicates easier to read. Tested on x86, x86_64 and ppc64. Diego.