[EMAIL PROTECTED] wrote on 06/09/2005 02:43:37 PM:
> cc1: warnings being treated as errors
> /home/pthaugen/work/src/mainline/gcc/gcc/config/rs6000/rs6000.c:12538:
> warning: ‘rs6000_invalid_within_doloop’ defined but not used
ChangeLog looks odd on this, Adrian changed the name of prototype and then
later Daniel came along and fixed prototype of "old" name.
2005-06-09 Daniel Berlin <[EMAIL PROTECTED]>
* config/rs6000/rs6000.c: (rs6000_insn_valid_within_doloop): Fix
prototype.
...
2005-06-09 Adrian Straetling <[EMAIL PROTECTED]>
* target.h (insn_valid_within_doloop): Rename into
"invalid_within_doloop". Change return type to "const char *".
Update Comment.
* targhooks.h (default_insn_valid_within_doloop): Rename into
"default_invalid_within_doloop".
* targhooks.c (default_insn_valid_within_doloop): Likewise.
Update Comment.
* target-def.h (TARGET_INSN_VALID_WITHIN_DOLOOP): Rename target hook
into "TARGET_INVALID_WITHIN_DOLOOP". Default it to
"default_invalid_within_doloop".
* hooks.c (hook_constcharptr_rtx_null): New function.
(hook_bool_rtx_true): Remove.
* hooks.h (hook_constcharptr_rtx_null): Declare.
(hook_bool_rtx_true): Remove.
* loop-doloop.c (doloop_valid_p): Temporarily store return value of
"invalid_within_doloop" and print error message if non-null.
Update Comment.
* doc/tm.texi: Update documentation.
* config/s390/s390.c: Adjust to new hook name and new default hook.
* config/rs6000/rs6000.c: (rs6000_insn_valid_within_doloop): Rename
into "rs6000_invalid_within_doloop".
(rs6000_invalid_within_doloop): Change return type to "static const
char *" and replace return values. Update Comment.