Hi!
This message primerely concernce java but I think the question is of general interest so I post it here and hope that this is OK.
I jumped on one of the newbe gcc hackers quests described at http://gcc.gnu.org/projects/#beginner_gcc_hackers .
More precisely I started to clean up the long actions in gcc/java/parse.y. Happy that the thing still compiled after my
first attack, I decided to be a little more serious. My problems:
Currently I have placed the factor out functions in a files named parse_factor.c (and .h). I feel this is a somewhat bad name,
is there any rule for file naming in use at gcc.
The functions that replaces the actions I call the same as the actions left hand side nonterminal with a _ and a number
added, thus the two rules for array_type in parse.y looks like this after the change:
array_type:
primitive_type dims
{
$$ = array_type_1(ctxp,($1));
}
| name dims
{
$$ = array_type_2(ctxp,($1));
}
;
Is this good (at least it is easy to find the place they are used even if the names aren't any "implicit comments" on the code).
Regards David