On Tue, Sep 17, 2013 at 7:37 PM, Richard Sandiford <rdsandif...@googlemail.com> wrote: > Mike Stump <mikest...@comcast.net> writes: >> +/* Partial integer modes are specified by relation to a full integer >> + mode. */ >> +#define PARTIAL_INT_MODE(M,PREC) \ >> + make_partial_integer_mode (#M, "P" #PREC #M, PREC, __FILE__, __LINE__) >> +/* Partial integer modes are specified by relation to a full integer >> + mode. */ >> +#define PARTIAL_INT_MODE_NAME(M,PREC,NAME) \ >> + make_partial_integer_mode (#M, #NAME, PREC, __FILE__, __LINE__) > > Sorry for the bikeshedding, but I think it'd better to have a single macro: > > #define PARTIAL_INT_MODE(M, PREC, NAME) > > You can easily add an explicit "P<n><mode>" if the port happens to want > that name.
I agree. Btw, the "implementation defined" precision of PDI on SH-5 definitely looks interesting, but I wonder how you can perform "implementation defined" arithmetic on that PDI mode then ;) I suppose using the maximum precision of 64 bits is good enough, assuming the rest of the bits get truncated in "implementation defined" manners. What else blocks this patch? Thanks, Richard. > Thanks, > Richard