Mike Stump <mikest...@comcast.net> writes: > +/* Partial integer modes are specified by relation to a full integer > + mode. */ > +#define PARTIAL_INT_MODE(M,PREC) \ > + make_partial_integer_mode (#M, "P" #PREC #M, PREC, __FILE__, __LINE__) > +/* Partial integer modes are specified by relation to a full integer > + mode. */ > +#define PARTIAL_INT_MODE_NAME(M,PREC,NAME) \ > + make_partial_integer_mode (#M, #NAME, PREC, __FILE__, __LINE__)
Sorry for the bikeshedding, but I think it'd better to have a single macro: #define PARTIAL_INT_MODE(M, PREC, NAME) You can easily add an explicit "P<n><mode>" if the port happens to want that name. Thanks, Richard