On Tue, Sep 25, 2012 at 4:30 PM, Lawrence Crowl <cr...@google.com> wrote: > On 8/15/12, Richard Henderson <r...@redhat.com> wrote: >> On 2012-08-15 07:29, Richard Guenther wrote: >> > + typedef typename Element::Element_t Element_t; >> >> Can we use something less ugly than Element_t? >> Such as >> >> typedef typename Element::T T; >> >> ? Given that this name is scoped anyway... > > I've been finding the use of T as a typedef confusing. It sort of > flies in the face of all existing convention. The C++ standard would > use either element_type or value_type. I suggest a rename, but I'm > guessing that folks don't want something as verbose as element_type. > How about elemtype? Any objections to me changing it to that? >
In general, we would be better off following standard convention. It does not seem to me that we have enough reasons and benefits in building our own universe around this issue. Consequently, I would suggest that we use value_type or element_type in the interface -- which is better served being readable: this is the *interface*. I am pretty sure that people will quickly resort to local typedefs that are more readable even if we adopt a short (therefore cryptic) abbreviations such as T in the interface. It is one more hurdle that has no reason to be. -- Gaby