On 7/11/22 14:24, Rui Ueyama wrote: > I updated my patch to support the proposed API: > https://github.com/rui314/mold/commit/22bbfa9bba9beeaf40b76481d175939ee2c62ec8 > > Martin, > > I think you want to apply this patch. Currently, your API always > passes LAPI_V0 as the maximum API version.
Are you sure? The function signature is: (*ld_plugin_get_api_version) (const char *plugin_identifier, const char *plugin_version, enum linker_api_version minimal_api_supported, enum linker_api_version maximal_api_supported, ... Which means the plug-in always set minimal as LAPI_V0 and maximal LAPI_V0/V1. That seems correct to me. Martin > > diff --git a/lto-plugin/lto-plugin.c b/lto-plugin/lto-plugin.c > index e9afd2fb76d..c97bda9de91 100644 > --- a/lto-plugin/lto-plugin.c > +++ b/lto-plugin/lto-plugin.c > @@ -1441,15 +1441,15 @@ negotiate_api_version (void) > const char *linker_version; > > enum linker_api_version supported_api = LAPI_V0; > #if HAVE_PTHREAD_LOCKING > supported_api = LAPI_V1; > #endif > > - api_version = get_api_version ("GCC", BASE_VERSION, LAPI_V0, > + api_version = get_api_version ("GCC", BASE_VERSION, LAPI_V1, > supported_api, &linker_identifier, > &linker_version); > if (api_version > supported_api) > { > fprintf (stderr, "requested an unsupported API version (%d)\n", > api_version); > abort (); > } > > On Mon, Jul 11, 2022 at 6:51 PM Martin Liška <mli...@suse.cz> wrote: >> >> On 7/11/22 11:55, Richard Biener wrote: >>> On Mon, Jul 11, 2022 at 11:16 AM Alexander Monakov <amona...@ispras.ru> >>> wrote: >>>> >>>> On Mon, 11 Jul 2022, Rui Ueyama wrote: >>>> >>>>>> but ignoring min_api_supported is wrong, and assuming max_api_supported >>>>>> > 0 >>>>>> is also wrong. It really should check how given [min; max] range >>>>>> intersects >>>>>> with its own range of supported versions. >>>>> >>>>> Currently only one version is defined which is LAPI_V1. I don't think >>>>> LAPI_UNSPECIFIED is a version number; rather, it's an unspecified >>>>> value. No ordering should be defined between a defined value and an >>>>> unspecified value. If LAPI_UNSPECIFIED < LAPI_V1, it should be renamed >>>>> LAPI_V0. >>>> >>>> You still cannot rely on API guarantees of LAPI_V1 when the plugin does not >>>> advertise it (thread safety of claim_file in this particular case). >>> >> >> Hi. >> >> All right, I think we should rename LAPI_UNSPECIFIED to LAPI_V0 in order >> to support minimal_api_supported == LAPI_V0. >> >>> So with LAPI_UNSPECIFIED all the plugin gets is the linker name and version. >>> Clarifying the documentation on LAPI_UNSPECIFIED might be nice, also >>> what the expectation is on the linker when the plugin returns >>> LAPI_UNSPECIFIED when it speficied minimal_api_supported == V1. >> >> I've clarified that linker should return a value that is in range >> [minimal_api_supported, maximal_api_supported] and added an abort >> if it's not the case. >> >> Having that, mold should respect if maximal_api_supported == LAPI_V0 is >> returned >> by a plug-in (happens now as we miss locking for some targets). >> >> Martin >> >>> "minimal_api_supported == LAPI_UNSPECIFIED" does not make much >>> sense if using Ruis reading of this value? >>> >>>> And you still should check the intersection of supported API ranges >>>> and give a sane diagnostic when min_api_supported advertised by the plugin >>>> exceeds LAPI_V1 (though, granted, the plugin could error out as well in >>>> this >>>> case). >>>> >>>> Alexander