On Tue, Jul 28, 2015 at 01:04:59PM +0200, Sebastian Huber wrote:
> libgomp/ChangeLog
> 2015-07-28  Sebastian Huber  <sebastian.hu...@embedded-brains.de>
> 
>       * config/posix/pool.h (gomp_adjust_thread_attr): New.
>       * config/rtems/pool.h (gomp_adjust_thread_attr): Likewise.
>       (gomp_thread_pool_reservoir): Add priority member.
>       * confi/rtems/proc.c (allocate_thread_pool_reservoir): Add
>       priority.
>       (parse_thread_pools): Likewise.
>       * team.c (gomp_team_start): Rename thread_attr to mutable_attr.
>       Call configuration provided gomp_adjust_thread_attr(). Destroy
>       mutable attributes if necessary.
>       * libgomp.texi: Document GOMP_RTEMS_THREAD_POOLS.

Wonder if the RTEMS specific bits in libgomp.texi shouldn't be guarded
with
@ifset RTEMS
...
@end ifset
and --texinfo='@set RTEMS' be used when compiling it.
But perhaps it can be done incrementally, so the patch is ok.

> @@ -292,7 +292,7 @@ gomp_team_start (void (*fn) (void *), void *data, 
> unsigned nthreads,
>    bool nested;
>    struct gomp_thread_pool *pool;
>    unsigned i, n, old_threads_used = 0;
> -  pthread_attr_t thread_attr, *attr;
> +  pthread_attr_t mutable_attr, *attr;

Just wonder why have you renamed this variable.  It is a thread attribute
after all, even after your changes.  mutable_attr doesn't make much sense to
me.

        Jakub

Reply via email to