On Mon, Jun 15, 2015 at 10:48:50PM +0300, Ilya Verbin wrote: > Here is the new patch. OK to commit? > > > gcc/ > * builtin-types.def (BT_FN_VOID_INT_OMPFN_SIZE_PTR_PTR_PTR): New. > (BT_FN_VOID_INT_OMPFN_PTR_SIZE_PTR_PTR_PTR): Remove. > * omp-builtins.def (BUILT_IN_GOMP_TARGET): Replace GOMP_target with > GOMP_target_41. > (BUILT_IN_GOMP_TARGET_DATA): Replace GOMP_target_data with > GOMP_target_data_41. > (BUILT_IN_GOMP_TARGET_ENTER_EXIT_DATA): New. > * omp-low.c (expand_omp_target): Use > BUILT_IN_GOMP_TARGET_ENTER_EXIT_DATA for GF_OMP_TARGET_KIND_ENTER_DATA > and GF_OMP_TARGET_KIND_EXIT_DATA. > Do not pass obsolete pointer to new builtins. > (lower_omp_target): Use unsigned short for map kinds, except > BUILT_IN_GOMP_TARGET_UPDATE. > gcc/fortran/ > * types.def (BT_FN_VOID_INT_OMPFN_SIZE_PTR_PTR_PTR): New. > (BT_FN_VOID_INT_OMPFN_PTR_SIZE_PTR_PTR_PTR): Remove. > libgomp/ > * libgomp.map (GOMP_4.1): Add GOMP_target_41, GOMP_target_data_41, > GOMP_target_enter_exit_data. > * libgomp_g.h: Declare GOMP_target_41, GOMP_target_data_41, > GOMP_target_enter_exit_data. > * target.c (resolve_device): Call gomp_init_device here instead of > GOMP_target*. > (get_kind): Rename is_openacc to short_mapkind. > (gomp_map_vars): Likewise. > (gomp_unmap_vars): Likewise. > (gomp_update): Likewise. > (gomp_target_fallback): New static function. > (gomp_get_target_fn_addr): New static function. > (GOMP_target): Move host fallback and fn lookup to the new functions. > (GOMP_target_41): New function. > (gomp_target_data_fallback): New static function. > (GOMP_target_data): Move host fallback to the new function. > (GOMP_target_data_41): New function. > (GOMP_target_update): Do not call gomp_init_device. > (GOMP_target_enter_exit_data): New function.
Ok, thanks. Jakub