On Mon, Nov 01, 2021 at 06:32:51PM +0100, Thomas Koenig wrote: > f->value.function.name > = gfc_get_string (PREFIX ("matmul_%c%d"), gfc_type_letter (f->ts.type), > f->ts.kind); > > Easy enough to add something there if ts.type is BT_REAL, > ts.kind is 16 and the compiler is currently using > double double (for example), or just use KIND=15 then > (although that would only be a naming convention).
Note, if we go the way of C/C++ with -mabi=ieeelongdouble vs. -mabi=ibmlongdouble choosing between the two ABIs and libgfortran being ABI compatible with both, then we don't need to bump soname. But, if we don't bump it, we need to keep double double there backwards compatible (i.e. _r16 etc. being the double double, not IEEE). When in the future we bump the soname, we can swap those two and make _r16 newly stand for IEEE quad and _r15 or _r16d or whatever for double double. Jakub