Hi! On Monday 14 December 2015 09:25:01 am Eran Kornblau wrote:
> diff --git a/libavformat/isom.h b/libavformat/isom.h > index a082e40..3b0230a 100644 > --- a/libavformat/isom.h > +++ b/libavformat/isom.h > @@ -37,6 +37,8 @@ extern const AVCodecTag ff_codec_movsubtitle_tags[]; > int ff_mov_iso639_to_lang(const char lang[4], int mp4); > int ff_mov_lang_to_iso639(unsigned code, char to[4]); > > +struct AVAESCTR; Is this needed? > + subsample_count = AV_RB16(sc->cenc.auxiliary_info_pos); > + sc->cenc.auxiliary_info_pos += sizeof(uint16_t); I find the following significantly easier to read and understand: subsample_count = AV_RB16(sc->cenc.auxiliary_info_pos); sc->cenc.auxiliary_info_pos += 2; But this may just be me, so feel free to ignore. I suspect a fate test will be needed but this may be an independent patch. Thank you, Carl Eugen _______________________________________________ ffmpeg-devel mailing list ffmpeg-devel@ffmpeg.org http://ffmpeg.org/mailman/listinfo/ffmpeg-devel