On 12/14/24 00:39, Marth64 wrote:
This makes sense to me now.
I think it makes more sense to follow the A53
approach and be consistent.
May I suggest the following in the patch to also
improve readability in this crowded area of code:
- SCTE-20 section: as you are declaring `cap` to be
`s1->a53_buf_ref->data + old_size` now, the memset
immediately following the declaration can be shortened
to `memset(cap, 0, cc_count * 3);`
I did see that but was trying to have a minimal patch; however, that is
reasonable to also change.
- DVB 0502 section: rename `uint8_t* data` to `uint8_t *cap`
when you are setting up the final payload.
This makes it more consistent with the other sections.
I had thought about consistency, but I really didn't like the name
`cap`. However, I suppose it is short for `captions`, so I will also
use `cap` for better consistency.
Regards,
Scott Theisen
_______________________________________________
ffmpeg-devel mailing list
ffmpeg-devel@ffmpeg.org
https://ffmpeg.org/mailman/listinfo/ffmpeg-devel
To unsubscribe, visit link above, or email
ffmpeg-devel-requ...@ffmpeg.org with subject "unsubscribe".