-----Original Message-----
From: ffmpeg-devel <ffmpeg-devel-boun...@ffmpeg.org> On Behalf Of Lynne
Sent: Sunday, July 9, 2023 3:11 PM
To: FFmpeg development discussions and patches <ffmpeg-devel@ffmpeg.org>
Subject: RE: [EXTERNAL][FFmpeg-devel] [PATCH] lavu: add AVVideoHint API

CAUTION: This email originated from outside of the organization. Do not click 
links or open attachments unless you can confirm the sender and know the 
content is safe.



Jul 9, 2023, 13:05 by an...@khirnov.net:

> From: Elias Carotti <eliascrt _at_ amazon _dot_ it>
>
> Add side data type to provide hint to the video encoders about 
> unchanged portions of each frame.
>
> Signed-off-by: Anton Khirnov <an...@khirnov.net>
> ---
> I've made couple small changes:
> * rebased against current master
> * consistently refer to rectangles or AVVideoRect, not blocks
> * use size_t instead of int for AVVideoHint.nb_rects
> * build unconditionally -- this is public API, it must always be  
> available regardless of what encoders are or are not available
> * tweaked documentation
>
> If you have no objections to the changes, I'll push this in a few days.
> ---
>  doc/APIchanges         |   3 ++
>  libavutil/Makefile     |   2 +
>  libavutil/frame.h      |  10 ++++
>  libavutil/version.h    |   2 +-
>  libavutil/video_hint.c |  82 +++++++++++++++++++++++++++++++  
> libavutil/video_hint.h | 108 +++++++++++++++++++++++++++++++++++++++++
>  6 files changed, 206 insertions(+), 1 deletion(-)  create mode 100644 
> libavutil/video_hint.c  create mode 100644 libavutil/video_hint.h
>

AVVideoHint is a bad name for something like this.
Could you borrow some wording from graphics and call it AVVideoDamagedHint or 
maybe AVVideoChangedAreaHint or a combination of both?
I'd prefer the former, damage is standard language in graphics circles about 
what has changed since the last frame.

Hi,
I have no strong objections on this. Personally I also like the 
AVVideoDamagedHint name best, my only concern is that it is strictly related to 
the current use/implementation 
(it's true right now that's the only kind of hint) while it may turn out to be 
a bad naming decision should other forms of hinting for the encoder be added in 
the future.
That said, I am fine with the change too.
Elias

_______________________________________________
ffmpeg-devel mailing list
ffmpeg-devel@ffmpeg.org
https://ffmpeg.org/mailman/listinfo/ffmpeg-devel

To unsubscribe, visit link above, or email ffmpeg-devel-requ...@ffmpeg.org with 
subject "unsubscribe".



NICE SRL, viale Monte Grappa 3/5, 20124 Milano, Italia, Registro delle Imprese 
di Milano Monza Brianza Lodi REA n. 2096882, Capitale Sociale: 10.329,14 EUR 
i.v., Cod. Fisc. e P.IVA 01133050052, Societa con Socio Unico



_______________________________________________
ffmpeg-devel mailing list
ffmpeg-devel@ffmpeg.org
https://ffmpeg.org/mailman/listinfo/ffmpeg-devel

To unsubscribe, visit link above, or email
ffmpeg-devel-requ...@ffmpeg.org with subject "unsubscribe".

Reply via email to