On Thu, Sep 18, 2014 at 12:16:42AM +0200, Andreas Cadhalpun wrote:
> Hi,
> 
> FFmpeg failed to build in Debian on powerpc/ppc64el with the
> following error:
> libavfilter/deshake.h:51:24: warning: declaration does not declare anything
>      MotionVector vector;  ///< Motion vector
>                         ^
> libavfilter/vf_deshake.c: In function 'find_motion':
> libavfilter/vf_deshake.c:297:20: error: expected identifier before
> '__attribute__'
>                  t->vector.x = x - deshake->rx;
>                     ^
> 
> Attached patch fixes this problem by renaming vector to vec.
> 
> Best regards,
> Andreas

>  deshake.h    |    2 +-
>  vf_deshake.c |   50 +++++++++++++++++++++++++-------------------------
>  2 files changed, 26 insertions(+), 26 deletions(-)
> fc1e8bc509d59d55b3cc68b37f78c749707195c0  
> vf_deshake-rename-Transform.vector-to-Transform.vec-.patch
> From 4288c94547fff0cbe6a3065f529bc8d732f61308 Mon Sep 17 00:00:00 2001
> From: Andreas Cadhalpun <andreas.cadhal...@googlemail.com>
> Date: Thu, 18 Sep 2014 00:08:05 +0200
> Subject: [PATCH] vf_deshake: rename Transform.vector to Transform.vec to avoid
>  compiler confusion

applied

thanks

[...]

-- 
Michael     GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB

Its not that you shouldnt use gotos but rather that you should write
readable code and code with gotos often but not always is less readable

Attachment: signature.asc
Description: Digital signature

_______________________________________________
ffmpeg-devel mailing list
ffmpeg-devel@ffmpeg.org
http://ffmpeg.org/mailman/listinfo/ffmpeg-devel

Reply via email to