First of all please stop sending your patches as a reply to an earlier and completely unrelated series.
Second please prefix all TTM related patches with "drm/ttm:". Additional to that I don't really see the point in renaming some of the jump labels, if you call it "restart" or "lock_restart" doesn't make much difference. Regards, Christian. Am 22.09.2016 um 19:32 schrieb SF Markus Elfring: > From: Markus Elfring <elfring at users.sourceforge.net> > Date: Thu, 22 Sep 2016 19:00:01 +0200 > > Several update suggestions were taken into account > from static source code analysis. > > Markus Elfring (14): > Use kmalloc_array() in two functions > Rename a jump label in ttm_alloc_new_pages() > Rename jump labels in ttm_page_pool_free() > Rename a jump label in ttm_page_pool_get_pages() > Use kmalloc_array() in two more functions > Rename a jump label in ttm_dma_pool_alloc_new_pages() > Rename jump labels in ttm_dma_page_pool_free() > Rename a jump label in ttm_dma_pool_shrink_scan() > Return directly after a failed kzalloc() in ttm_dma_page_alloc_init() > Return directly after a failed kobject_init_and_add() in > ttm_dma_page_alloc_init() > Return an error code only as a constant in ttm_dma_pool_init() > Less function calls in ttm_dma_pool_init() after error detection > Delete unnecessary variable initialisations in ttm_dma_pool_init() > Mark an array of text strings as "const" in ttm_dma_pool_init() > > drivers/gpu/drm/ttm/ttm_page_alloc.c | 30 ++++++++--------- > drivers/gpu/drm/ttm/ttm_page_alloc_dma.c | 58 > +++++++++++++++----------------- > 2 files changed, 42 insertions(+), 46 deletions(-) >