devel
Thread
Date
Earlier messages
Messages by Thread
[PATCH] qemu: qemuDomainRenameCallback: tidy up
Roman Bogorodskiy
[PATCH v2 0/5] virsh: Add missing TAB completers for several commands
Radosław Śmigielski via Devel
[PATCH v2 1/5] virsh: Add vshCompletePathLocalCreate completer for output paths
Radosław Śmigielski via Devel
[PATCH v2 2/5] virsh: Add completer for '--type' option of 'domdisplay' command
Radosław Śmigielski via Devel
[PATCH v2 3/5] virsh: Add completer for '--format' option of 'domxml-from-native' command
Radosław Śmigielski via Devel
[PATCH v2 4/5] virsh: Add missing TAB completers for several options
Radosław Śmigielski via Devel
[PATCH v2 5/5] virsh: Add missing TAB completers for 'attach-disk' command
Radosław Śmigielski via Devel
[PATCH 0/3] bhyve: implement virDomainSetLifecycleAction() API
Roman Bogorodskiy
[PATCH 1/3] bhyve: add validation for lifecycle actions
Roman Bogorodskiy
[PATCH 3/3] bhyve: implement virDomainSetLifecycleAction() API
Roman Bogorodskiy
[PATCH 2/3] bhyve: monitor: respect on_poweroff / on_reboot settings
Roman Bogorodskiy
[PATCH 0/3] bhyve: improve domain startup error handling
Roman Bogorodskiy
[PATCH 1/3] bhyve: error handling for monitor opening
Roman Bogorodskiy
Re: [PATCH 1/3] bhyve: error handling for monitor opening
Peter Krempa via Devel
[PATCH 2/3] bhyve: improve domain startup error handling
Roman Bogorodskiy
Re: [PATCH 2/3] bhyve: improve domain startup error handling
Peter Krempa via Devel
[PATCH 3/3] bhyve: clear monitor reference on close
Roman Bogorodskiy
Re: [PATCH 3/3] bhyve: clear monitor reference on close
Peter Krempa via Devel
[PATCH v18 03/14] net/tap: deprecate "no" as special value for script/downscript
Vladimir Sementsov-Ogievskiy
Re: [PATCH v18 03/14] net/tap: deprecate "no" as special value for script/downscript
Markus Armbruster via Devel
Re: [PATCH v18 03/14] net/tap: deprecate "no" as special value for script/downscript
Vladimir Sementsov-Ogievskiy
Re: [PATCH v18 03/14] net/tap: deprecate "no" as special value for script/downscript
Daniel P . Berrangé via Devel
Re: [PATCH v18 03/14] net/tap: deprecate "no" as special value for script/downscript
Vladimir Sementsov-Ogievskiy
[PATCH 0/6] conf: add vlen tag for RISC-V CPUs
Heinrich Schuchardt via Devel
[PATCH 6/6] docs: add vlen to formatdomain documentation
Heinrich Schuchardt via Devel
[PATCH 1/6] conf: add vlen tag for RISC-V CPUs
Heinrich Schuchardt via Devel
[PATCH 3/6] qemu: validate that CPU vlen is only used with RISC-V
Heinrich Schuchardt via Devel
[PATCH 2/6] schemas: add cpuVlen definition for RISC-V vector length
Heinrich Schuchardt via Devel
[PATCH 5/6] tests: provide vlen configuration test
Heinrich Schuchardt via Devel
[PATCH 4/6] qemu: emit vlen= CPU property on the command line
Heinrich Schuchardt via Devel
[libvirt PATCH 0/4] network: reject line breaks in DNS records emitted to dnsmasq
Michael Bommarito
[libvirt PATCH 1/4] conf: reject line breaks in DNS TXT record values
Michael Bommarito
[libvirt PATCH 2/4] conf: reject line breaks in DNS SRV domain and target
Michael Bommarito
[libvirt PATCH 3/4] network: reject line breaks before writing dnsmasq DNS config
Michael Bommarito
[libvirt PATCH 4/4] tests: cover line-break rejection in DNS TXT and SRV records
Michael Bommarito
[PATCH 0/6] qemu: Support AF_VSOCK transport for QGA communication
Polina Vishneva via Devel
[PATCH 3/6] qemu: Add qemuDomainVsockHasGuestCid helper
Polina Vishneva via Devel
[PATCH 6/6] tests: Add a test for qemuConnectAgent() to cover the vsock path
Polina Vishneva via Devel
[PATCH 1/6] util: Add virVsockConnectQuiet helper
Polina Vishneva via Devel
[PATCH 2/6] qemu: Extract qemuProcessResetAgent helper
Polina Vishneva via Devel
[PATCH 5/6] tests: Add a unit test for virVsockConnectQuiet()
Polina Vishneva via Devel
[PATCH 4/6] qemu: Support AF_VSOCK transport for QGA communication
Polina Vishneva via Devel
[PATCH 0/6] virsh: Add missing TAB completers for several commands
Radosław Śmigielski via Devel
[PATCH 1/6] virsh: Add completer for '--file' option of 'dump' subcommand
Radosław Śmigielski via Devel
Re: [PATCH 1/6] virsh: Add completer for '--file' option of 'dump' subcommand
Peter Krempa via Devel
Re: [PATCH 1/6] virsh: Add completer for '--file' option of 'dump' subcommand
Peter Krempa via Devel
[PATCH 2/6] virsh: Add completer for '--dest' option of 'blockcopy' command
Radosław Śmigielski via Devel
Re: [PATCH 2/6] virsh: Add completer for '--dest' option of 'blockcopy' command
Peter Krempa via Devel
[PATCH 3/6] virsh: Add completer for '--type' option of 'detach-interface' command
Radosław Śmigielski via Devel
Re: [PATCH 3/6] virsh: Add completer for '--type' option of 'detach-interface' command
Peter Krempa via Devel
[PATCH 4/6] virsh: Add completer for '--type' option of 'domdisplay' command
Radosław Śmigielski via Devel
Re: [PATCH 4/6] virsh: Add completer for '--type' option of 'domdisplay' command
Peter Krempa via Devel
[PATCH 5/6] virsh: Add completer for '--format' option of 'domxml-from-native' command
Radosław Śmigielski via Devel
[PATCH 6/6] virsh: Add completer for '--file' option of 'save' command
Radosław Śmigielski via Devel
[PATCH] node_device_udev: fix deadlock joining udev thread under lock
Christopher Johannimloh
[PATCH v2] vbox: fix memory leak in vboxStartMachine()
Elizaveta Tereshkina via Devel
[PATCH] docs: drvnetwork: Update sample pf.conf to include NAT forwarding for FreeBSD
Nimish Jain
Re: [PATCH] docs: drvnetwork: Update sample pf.conf to include NAT forwarding for FreeBSD
Roman Bogorodskiy
[PATCH] docs: drvbhyve: document newly added pf check
Nimish Jain
Re: [PATCH] docs: drvbhyve: document newly added pf check
Roman Bogorodskiy
[PATCH] vbox: fix memory leak in vboxStartMachine()
Elizaveta Tereshkina
Re: [PATCH] vbox: fix memory leak in vboxStartMachine()
Ján Tomko via Devel
RFC: GitLab confidential issues for security disclosures ?
Daniel P . Berrangé via Devel
Re: RFC: GitLab confidential issues for security disclosures ?
Ján Tomko via Devel
Re: RFC: GitLab confidential issues for security disclosures ?
Daniel P . Berrangé via Devel
[RFC PATCH v2 0/5] Arm CPU features with supported values
sandesh . patel
[RFC PATCH v2 1/5] Add QEMU_CAPS_QUERY_ARM_CPU_PROPS_INFO
sandesh . patel
[RFC PATCH v2 2/5] Add support to query ARM CPU property values
sandesh . patel
[RFC PATCH v2 3/5] Cache and load ARM CPU property information
sandesh . patel
[RFC PATCH v2 5/5] Support 'value' attribute on CPU features
sandesh . patel
[PATCH 0/4] qemu: auto-select win-dmp for Windows guest crash dumps
Denis V. Lunev via Devel
[PATCH 1/4] qemu: auto-select win-dmp for crash- and watchdog-triggered dumps
Denis V. Lunev via Devel
[PATCH 2/4] util: add virStrToBytes() and virConfGetValueBytes() for scaled sizes
Denis V. Lunev via Devel
[PATCH 3/4] logging: accept a unit suffix in virtlogd's max_size
Denis V. Lunev via Devel
[PATCH 4/4] qemu: cap total size of auto-triggered dumps under auto_dump_path
Denis V. Lunev via Devel
Re: [PATCH 4/4] qemu: cap total size of auto-triggered dumps under auto_dump_path
Daniel P . Berrangé via Devel
Re: [PATCH 4/4] qemu: cap total size of auto-triggered dumps under auto_dump_path
Denis V. Lunev via Devel
[PATCH v2 0/1] lxc: fix problem with truncation of long path used for file backing block device
Radosław Śmigielski via Devel
[PATCH v2 1/1] lxc: fix problem with truncation of long path used for file backing block device
Radosław Śmigielski via Devel
[PATCH v7 00/35] monitor: turn QMP and HMP into QOM objects
Daniel P . Berrangé via Devel
[PATCH v7 01/35] qom: replace 'can_be_deleted' with 'prepare_delete'
Daniel P . Berrangé via Devel
Re: [PATCH v7 01/35] qom: replace 'can_be_deleted' with 'prepare_delete'
Markus Armbruster via Devel
[PATCH v7 02/35] monitor: replace 'common' with 'parent_obj' in MonitorHMP
Daniel P . Berrangé via Devel
[PATCH v7 03/35] monitor: replace 'common' with 'parent_obj' in MonitorQMP
Daniel P . Berrangé via Devel
[PATCH v7 04/35] monitor: rename monitor_init* to monitor_new*
Daniel P . Berrangé via Devel
[PATCH v7 06/35] monitor: pass chardev ID into monitor constructor instead of object
Daniel P . Berrangé via Devel
Re: [PATCH v7 06/35] monitor: pass chardev ID into monitor constructor instead of object
Markus Armbruster via Devel
Re: [PATCH v7 06/35] monitor: pass chardev ID into monitor constructor instead of object
Marc-André Lureau via Devel
[PATCH v7 09/35] monitor: add 'pretty' property to QMP Monitor class
Daniel P . Berrangé via Devel
[PATCH v7 08/35] monitor: add 'readline' property to HMP Monitor class
Daniel P . Berrangé via Devel
[PATCH v7 05/35] monitor: minimal conversion of monitors to QOM
Daniel P . Berrangé via Devel
Re: [PATCH v7 05/35] monitor: minimal conversion of monitors to QOM
Markus Armbruster via Devel
Re: [PATCH v7 05/35] monitor: minimal conversion of monitors to QOM
Markus Armbruster via Devel
Re: [PATCH v7 05/35] monitor: minimal conversion of monitors to QOM
Daniel P . Berrangé via Devel
[PATCH v7 07/35] monitor: add 'chardev' property to Monitor base class
Daniel P . Berrangé via Devel
[PATCH v7 10/35] monitor: remove 'skip_flush' field
Daniel P . Berrangé via Devel
[PATCH v7 13/35] monitor: use class methods for monitor_qapi_event_emit
Daniel P . Berrangé via Devel
[PATCH v7 12/35] monitor: use class methods for monitor_vprintf
Daniel P . Berrangé via Devel
[PATCH v7 14/35] monitor: use class methods for monitor_accept_input
Daniel P . Berrangé via Devel
[PATCH v7 11/35] monitor: move monitor_data_(init|destroy) into QOM init/finalize
Daniel P . Berrangé via Devel
[PATCH v7 16/35] monitor: use dynamic cast in monitor_qmp_requests_pop_any_with_lock
Daniel P . Berrangé via Devel
[PATCH v7 17/35] util: use dynamic cast in error vreport
Daniel P . Berrangé via Devel
[PATCH v7 19/35] monitor: use dynamic cast in QMP commands
Daniel P . Berrangé via Devel
[PATCH v7 21/35] monitor: drop unused monitor_is_qmp method
Daniel P . Berrangé via Devel
[PATCH v7 20/35] monitor: use dynamic cast in monitor_is_hmp_non_interactive
Daniel P . Berrangé via Devel
[PATCH v7 18/35] monitor: drop unused monitor_cur_is_qmp
Daniel P . Berrangé via Devel
[PATCH v7 15/35] monitor: use class method for I/O thread request
Daniel P . Berrangé via Devel
[PATCH v7 24/35] monitor: convert from oneshot BH to persistent BH
Daniel P . Berrangé via Devel
[PATCH v7 25/35] monitor: reject attempts to delete the current monitor
Daniel P . Berrangé via Devel
[PATCH v7 23/35] monitor: implement "user creatable" interface for adding monitors
Daniel P . Berrangé via Devel
[PATCH v7 26/35] monitor: protect qemu_chr_fe_accept_input with monitor lock
Daniel P . Berrangé via Devel
[PATCH v7 22/35] monitor: eliminate monitor_is_hmp_non_interactive method
Daniel P . Berrangé via Devel
[PATCH v7 27/35] monitor: implement support for deleting QMP objects
Daniel P . Berrangé via Devel
[PATCH v7 28/35] tests/qtest: add tests for dynamic monitor add/remove
Daniel P . Berrangé via Devel
[PATCH v7 29/35] tests/functional: add e2e test for dynamic QMP monitor hotplug
Daniel P . Berrangé via Devel
[PATCH v7 31/35] qom: add trace events for user creatable create/delete APIs
Daniel P . Berrangé via Devel
[PATCH v7 33/35] tests: switch from -mon to -object monitor-qmp
Daniel P . Berrangé via Devel
[PATCH v7 30/35] tests/functional: add a stress test for monitor hot unplug
Daniel P . Berrangé via Devel
[PATCH v7 32/35] monitor: add support for auto-deleting monitors upon close
Daniel P . Berrangé via Devel
Re: [PATCH v7 32/35] monitor: add support for auto-deleting monitors upon close
Markus Armbruster via Devel
[PATCH v7 34/35] qemu-options: document new monitor-hmp and monitor-qmp objects
Daniel P . Berrangé via Devel
Re: [PATCH v7 34/35] qemu-options: document new monitor-hmp and monitor-qmp objects
Markus Armbruster via Devel
[PATCH v7 35/35] docs: mark '-mon' as deprecated in favour of -object
Daniel P . Berrangé via Devel
Re: [PATCH v7 35/35] docs: mark '-mon' as deprecated in favour of -object
Markus Armbruster via Devel
Re: [PATCH v7 35/35] docs: mark '-mon' as deprecated in favour of -object
Markus Armbruster via Devel
Re: [PATCH v7 00/35] monitor: turn QMP and HMP into QOM objects
Markus Armbruster via Devel
[PATCH 0/2] virt-host-validate-bhyve: Improve checks
Nimish Jain
[PATCH 1/2] virHostValidateBhyve: replace if_tap check with if_tuntap check
Nimish Jain
[PATCH 2/2] virHostValidateBhyve: add pf check
Nimish Jain
Re: [PATCH 0/2] virt-host-validate-bhyve: Improve checks
Roman Bogorodskiy
[PATCH 0/2] bhyve: implement the virDomainRename API
Roman Bogorodskiy
[PATCH 1/2] bhyve: implement the virDomainRename API
Roman Bogorodskiy
Re: [PATCH 1/2] bhyve: implement the virDomainRename API
Peter Krempa via Devel
Re: [PATCH 1/2] bhyve: implement the virDomainRename API
Roman Bogorodskiy
Re: [PATCH 1/2] bhyve: implement the virDomainRename API
Peter Krempa via Devel
[PATCH 2/2] qemu: qemuDomainRenameCallback: remove unused variables
Roman Bogorodskiy
Re: [PATCH 2/2] qemu: qemuDomainRenameCallback: remove unused variables
Peter Krempa via Devel
[PATCH] docs: Fix example syntax error and update testing.rst
Radosław Śmigielski via Devel
[PATCH v4 RESEND 0/8] powerpc: Testcase improvements and Power8E/NVL removal
Aditya Gupta
[PATCH v4 RESEND 1/8] tests/functional: Add remote interrupts test for PowerNV
Aditya Gupta
Re: [PATCH v4 RESEND 1/8] tests/functional: Add remote interrupts test for PowerNV
Cédric Le Goater via Devel
Re: [PATCH v4 RESEND 1/8] tests/functional: Add remote interrupts test for PowerNV
Aditya Gupta
Re: [PATCH v4 RESEND 1/8] tests/functional: Add remote interrupts test for PowerNV
Cédric Le Goater via Devel
[PATCH v4 RESEND 2/8] tests/qtest/pnv_spi: Test Power11 PNV_SPI
Aditya Gupta
[PATCH v4 RESEND 3/8] tests/qtest: Add Power11 chip & machine to qtests
Aditya Gupta
[PATCH v4 RESEND 4/8] tests/functional: Use default powernv machine instead of power10
Aditya Gupta
[PATCH v4 RESEND 5/8] ppc/pnv: Replace Power8E with Power11 for 'none' machine test
Aditya Gupta
[PATCH v4 RESEND 6/8] ppc/pnv: Remove Power8E and Power8NVL pnv chips
Aditya Gupta
[PATCH v4 RESEND 7/8] ppc/pnv: Remove Power8E and Power8NVL CPUs
Aditya Gupta
[PATCH v4 RESEND 8/8] MAINTAINERS: Add self as maintainer for PowerNV
Aditya Gupta
Re: [PATCH v4 RESEND 8/8] MAINTAINERS: Add self as maintainer for PowerNV
Harsh Prateek Bora
Re: [PATCH v4 RESEND 8/8] MAINTAINERS: Add self as maintainer for PowerNV
Cédric Le Goater via Devel
[PATCH v6 00/34] monitor: turn QMP and HMP into QOM objects
Daniel P . Berrangé via Devel
[PATCH v6 01/34] qom: replace 'can_be_deleted' with 'prepare_delete'
Daniel P . Berrangé via Devel
Re: [PATCH v6 01/34] qom: replace 'can_be_deleted' with 'prepare_delete'
Markus Armbruster via Devel
Re: [PATCH v6 01/34] qom: replace 'can_be_deleted' with 'prepare_delete'
Daniel P . Berrangé via Devel
Re: [PATCH v6 01/34] qom: replace 'can_be_deleted' with 'prepare_delete'
Markus Armbruster via Devel
[PATCH v6 02/34] monitor: replace 'common' with 'parent_obj' in MonitorHMP
Daniel P . Berrangé via Devel
[PATCH v6 03/34] monitor: replace 'common' with 'parent_obj' in MonitorQMP
Daniel P . Berrangé via Devel
[PATCH v6 04/34] monitor: rename monitor_init* to monitor_new*
Daniel P . Berrangé via Devel
[PATCH v6 07/34] monitor: add 'readline' property to HMP Monitor class
Daniel P . Berrangé via Devel
[PATCH v6 05/34] monitor: minimal conversion of monitors to QOM
Daniel P . Berrangé via Devel
Re: [PATCH v6 05/34] monitor: minimal conversion of monitors to QOM
Markus Armbruster via Devel
Re: [PATCH v6 05/34] monitor: minimal conversion of monitors to QOM
Daniel P . Berrangé via Devel
Re: [PATCH v6 05/34] monitor: minimal conversion of monitors to QOM
Markus Armbruster via Devel
Re: [PATCH v6 05/34] monitor: minimal conversion of monitors to QOM
Daniel P . Berrangé via Devel
[PATCH v6 06/34] monitor: add 'chardev' property to Monitor base class
Daniel P . Berrangé via Devel
Re: [PATCH v6 06/34] monitor: add 'chardev' property to Monitor base class
Markus Armbruster via Devel
Re: [PATCH v6 06/34] monitor: add 'chardev' property to Monitor base class
Daniel P . Berrangé via Devel
[PATCH v6 08/34] monitor: add 'pretty' property to QMP Monitor class
Daniel P . Berrangé via Devel
[PATCH v6 09/34] monitor: remove 'skip_flush' field
Daniel P . Berrangé via Devel
[PATCH v6 11/34] monitor: use class methods for monitor_vprintf
Daniel P . Berrangé via Devel
[PATCH v6 10/34] monitor: move monitor_data_(init|destroy) into QOM init/finalize
Daniel P . Berrangé via Devel
[PATCH v6 12/34] monitor: use class methods for monitor_qapi_event_emit
Daniel P . Berrangé via Devel
[PATCH v6 13/34] monitor: use class methods for monitor_accept_input
Daniel P . Berrangé via Devel
[PATCH v6 16/34] util: use dynamic cast in error vreport
Daniel P . Berrangé via Devel
[PATCH v6 15/34] monitor: use dynamic cast in monitor_qmp_requests_pop_any_with_lock
Daniel P . Berrangé via Devel
[PATCH v6 14/34] monitor: use class method for I/O thread request
Daniel P . Berrangé via Devel
[PATCH v6 18/34] monitor: use dynamic cast in QMP commands
Daniel P . Berrangé via Devel
[PATCH v6 19/34] monitor: use dynamic cast in monitor_is_hmp_non_interactive
Daniel P . Berrangé via Devel
[PATCH v6 17/34] monitor: drop unused monitor_cur_is_qmp
Daniel P . Berrangé via Devel
[PATCH v6 20/34] monitor: drop unused monitor_is_qmp method
Daniel P . Berrangé via Devel
[PATCH v6 21/34] monitor: eliminate monitor_is_hmp_non_interactive method
Daniel P . Berrangé via Devel
[PATCH v6 22/34] monitor: implement "user creatable" interface for adding monitors
Daniel P . Berrangé via Devel
[PATCH v6 23/34] monitor: convert from oneshot BH to persistent BH
Daniel P . Berrangé via Devel
[PATCH v6 24/34] monitor: reject attempts to delete the current monitor
Daniel P . Berrangé via Devel
[PATCH v6 25/34] monitor: protect qemu_chr_fe_accept_input with monitor lock
Daniel P . Berrangé via Devel
[PATCH v6 30/34] qom: add trace events for user creatable create/delete APIs
Daniel P . Berrangé via Devel
[PATCH v6 29/34] tests/functional: add a stress test for monitor hot unplug
Daniel P . Berrangé via Devel
[PATCH v6 27/34] tests/qtest: add tests for dynamic monitor add/remove
Daniel P . Berrangé via Devel
[PATCH v6 28/34] tests/functional: add e2e test for dynamic QMP monitor hotplug
Daniel P . Berrangé via Devel
[PATCH v6 26/34] monitor: implement support for deleting QMP objects
Daniel P . Berrangé via Devel
[PATCH v6 32/34] tests: switch from -mon to -object monitor-qmp
Daniel P . Berrangé via Devel
[PATCH v6 31/34] monitor: add support for auto-deleting monitors upon close
Daniel P . Berrangé via Devel
Re: [PATCH v6 31/34] monitor: add support for auto-deleting monitors upon close
Markus Armbruster via Devel
Re: [PATCH v6 31/34] monitor: add support for auto-deleting monitors upon close
Daniel P . Berrangé via Devel
[PATCH v6 34/34] docs: mark '-mon' as deprecated in favour of -object
Daniel P . Berrangé via Devel
Re: [PATCH v6 34/34] docs: mark '-mon' as deprecated in favour of -object
Markus Armbruster via Devel
[PATCH v6 33/34] qemu-options: document new monitor-hmp and monitor-qmp objects
Daniel P . Berrangé via Devel
Re: [PATCH v6 33/34] qemu-options: document new monitor-hmp and monitor-qmp objects
Markus Armbruster via Devel
Earlier messages