BZ: https://bugzilla.tianocore.org/show_bug.cgi?id=3711

XenTimerDxe is a local Apic timer driver and it has nothing to do
with Xen. So rename it to LocalApicTimerDxe.

After renaming, LocalApicTimerDxe is used in OvmfPkg if CSM_ENABLE=FALSE.
Otherwise 8254 timer is used.

Patch #1:
Rename XenTimerDxe to LocalApicTimerDxe

Patch #2:
Switch timer in build time for OvmfPkg. If CSM_ENABLE=TRUE, 8254 timer
is used, otherwise the timer is LocalApicTimerDxe.

Code at: https://github.com/mxu9/edk2/tree/ovmf_lapic_timer

Cc: Ard Biesheuvel <ardb+tianoc...@kernel.org>
Cc: Jordan Justen <jordan.l.jus...@intel.com>
Cc: Brijesh Singh <brijesh.si...@amd.com>
Cc: Erdem Aktas <erdemak...@google.com>
Cc: James Bottomley <j...@linux.ibm.com>
Cc: Jiewen Yao <jiewen....@intel.com>
Cc: Tom Lendacky <thomas.lenda...@amd.com>
Cc: Gerd Hoffmann <kra...@redhat.com>
Signed-off-by: Min Xu <min.m...@intel.com>
Min Xu (2):
  OvmfPkg: Rename XenTimerDxe to LocalApicTimerDxe
  OvmfPkg: Switch timer in build time for OvmfPkg

 OvmfPkg/AmdSev/AmdSevX64.dsc                              | 3 +--
 OvmfPkg/AmdSev/AmdSevX64.fdf                              | 3 +--
 .../LocalApicTimerDxe.c}                                  | 7 +++----
 .../LocalApicTimerDxe.h}                                  | 4 ++--
 .../LocalApicTimerDxe.inf}                                | 6 +++---
 OvmfPkg/Microvm/MicrovmX64.dsc                            | 2 +-
 OvmfPkg/Microvm/MicrovmX64.fdf                            | 2 +-
 OvmfPkg/OvmfPkgIa32.dsc                                   | 6 +++++-
 OvmfPkg/OvmfPkgIa32.fdf                                   | 8 ++++++--
 OvmfPkg/OvmfPkgIa32X64.dsc                                | 6 +++++-
 OvmfPkg/OvmfPkgIa32X64.fdf                                | 8 ++++++--
 OvmfPkg/OvmfPkgX64.dsc                                    | 6 +++++-
 OvmfPkg/OvmfPkgX64.fdf                                    | 8 ++++++--
 OvmfPkg/OvmfXen.dsc                                       | 2 +-
 OvmfPkg/OvmfXen.fdf                                       | 2 +-
 15 files changed, 47 insertions(+), 26 deletions(-)
 rename OvmfPkg/{XenTimerDxe/XenTimerDxe.c => 
LocalApicTimerDxe/LocalApicTimerDxe.c} (95%)
 rename OvmfPkg/{XenTimerDxe/XenTimerDxe.h => 
LocalApicTimerDxe/LocalApicTimerDxe.h} (96%)
 rename OvmfPkg/{XenTimerDxe/XenTimerDxe.inf => 
LocalApicTimerDxe/LocalApicTimerDxe.inf} (86%)

-- 
2.29.2.windows.2



-=-=-=-=-=-=-=-=-=-=-=-
Groups.io Links: You receive all messages sent to this group.
View/Reply Online (#82915): https://edk2.groups.io/g/devel/message/82915
Mute This Topic: https://groups.io/mt/86671462/21656
Group Owner: devel+ow...@edk2.groups.io
Unsubscribe: https://edk2.groups.io/g/devel/unsub [arch...@mail-archive.com]
-=-=-=-=-=-=-=-=-=-=-=-


Reply via email to