On Tue, Oct 30, 2012 at 04:07:49PM +0200, Daniel Shahaf wrote: > Prabhu Gnana Sundar wrote on Tue, Oct 30, 2012 at 19:22:31 +0530: > > + if (err && keep_going) > > + { > > + svn_repos_notify_t *notify_failure; > > + notify_failure = svn_repos_notify_create(svn_repos_notify_failure, > > + iterpool); > > + notify_failure->err = err; > > + notify_func(notify_baton, notify_failure, iterpool); > > + svn_error_clear(err); > > + } > > + else > > + return svn_error_trace(err); > > This pattern repeats three times, maybe introduce a macro (like SVN_ERR, > SVN_INT_ERR, etc) to improve readability?
I'd prefer a new helper function instead of a new macro. Perhaps something like: if (err && keep_going) notify_verification_error(err, rev, pool); else SVN_ERR(err);