Hyrum K Wright wrote on Tue, Apr 24, 2012 at 18:36:28 -0500:
> On Tue, Apr 24, 2012 at 4:40 AM,  <danie...@apache.org> wrote:
> > Author: danielsh
> > Date: Tue Apr 24 09:40:45 2012
> > New Revision: 1329609
> >
> > URL: http://svn.apache.org/viewvc?rev=1329609&view=rev
> > Log:
> > Follow-up to r1329601:
> >
> > * subversion/include/svn_error.h
> >  (SVN_ERR_ASSERT2): New.
> 
> Our standard convention is that $SYMBOL(n) deprecates $SYMBOL(n-1).
> Does this deprecate the existing SVN_ERR_ASSERT() macro, or provide
> additional / different functionality?  If the former please note it as
> such, and we should attempt to convert the code to use the new macro.
> If the latter, please rename to something more descriptive.
> 

SVN_ERR_ASSERT(x) === SVN_ERR_ASSERT(x, SVN_NO_ERROR)

Still, I would prefer not to deprecate SVN_ERR_ASSERT() because that
would kill readability for the 99% common case.  So:

- I'll redefine SVN_ERR_ASSERT() as above
- I'll rename SVN_ERR_ASSERT2() to SVN_ERR_ASSERT_CHAIN()


> -Hyrum
> 
> > ...
> 
> 
> 
> -- 
> 
> uberSVN: Apache Subversion Made Easy
> http://www.uberSVN.com/

Reply via email to