Hi Yi,

- Event Builder Stream (p2): This will be part of different SEP, so we can
discuss alternatives then, but yea this system will leverage InMemorySystem
- Closable Task: sure will update it
- CollectionStreamSystem will be now changed to CollectionStreamSystemSpec
as per the discussion

Please let me know if any concerns.

Thanks

Sanil

On 17 May 2018 at 17:05, Yi Pan <nickpa...@gmail.com> wrote:

> Hi, Sanil,
>
> Thanks for the proposal! Overall, looks good to me. Here a few minor
> comments:
>
> - Event Builder Stream (p2): why do we need this instead of injecting
> events along w/ messages/timer function in CollectionStream?
>
> - Closable Task: if there is a per-task system resource opened, close()
> should close it (in the expected result column)
>
> - Why do we use CollectionStreamSystem? Prefer to rename it to
> CollectionStreamFactory to avoid the confusion to Samza’s input / output
> systems.
>
> - related, I think that the following code would make more sense with
> CollectionStreamFactory in the test code examples:
>
> {code}
>
> CollectionStreamFactory factory = new CollectionStreamFactory(…);
>
> CollectionStream output = factory.createOutput(“test”, “output”);
>
> CollectionStream input = factory.createInput(“test”, “input”, {1,2,3,4});
>
> …
>
> {code}
>
> Thanks!
>
> -Yi
>
> On Thu, May 17, 2018 at 11:57 AM, Fred Haifeng Ji <haifeng...@gmail.com>
> wrote:
>
> > +1
> >
> > On Thu, May 17, 2018 at 11:54 AM, santhosh venkat <
> > santhoshvenkat1...@gmail.com> wrote:
> >
> > > +1.
> > >
> > > Thanks.
> > >
> > > On Thu, May 17, 2018 at 10:13 AM, Jacob Maes <jacob.m...@gmail.com>
> > wrote:
> > >
> > > > +1
> > > >
> > > > On Thu, May 17, 2018 at 9:56 AM, Jagadish Venkatraman <
> > > > jagadish1...@gmail.com> wrote:
> > > >
> > > > > Thanks Sanil for the proposal. This will go a long way in
> simplifying
> > > > > testing of Samza applications.
> > > > >
> > > > > +1 (binding)
> > > > >
> > > > >
> > > > >
> > > > > On Thu, May 17, 2018 at 9:45 AM, Daniel Nishimura <
> > > dnishim...@gmail.com>
> > > > > wrote:
> > > > >
> > > > > > +1
> > > > > >
> > > > > > Looks great!
> > > > > >
> > > > > > On Thu, May 17, 2018 at 9:08 AM, Xinyu Liu <
> xinyuliu...@gmail.com>
> > > > > wrote:
> > > > > >
> > > > > > > +1
> > > > > > >
> > > > > > > The proposal looks great to me. Look forward to seeing the
> > > > > > implementation.
> > > > > > >
> > > > > > > Thanks,
> > > > > > > Xinyu
> > > > > > >
> > > > > > > On Wed, May 16, 2018 at 6:12 PM, Sanil Jain <
> > > sanil.jai...@gmail.com>
> > > > > > > wrote:
> > > > > > >
> > > > > > > > Hi All,
> > > > > > > >
> > > > > > > > This is a call for a vote for Samza's Integration Test
> > Framework
> > > as
> > > > > > > > described by:
> > > > > > > >
> > > > > > > > https://cwiki.apache.org/confluence/display/SAMZA/SEP-
> > > > > > > > 12%3A+Integration+Test+Framework
> > > > > > > >
> > > > > > > > The vote will be open for 3 days (ending at 6:00PM Monday,
> > > > > 05/21/2018).
> > > > > > > >
> > > > > > > > Link to the discuss mailing thread:
> > > > > > > >
> > > > > > > > http://mail-archives.apache.org/mod_mbox/samza-dev/201805.
> > mbox/%
> > > > > > > > 3CDM5PR21MB02827A6FA9F47CB8EF99A339A2810%40DM5PR21MB0282.
> > > > > > > > namprd21.prod.outlook.com%3E
> > > > > > > >
> > > > > > > >
> > > > > > > > Please vote:
> > > > > > > >
> > > > > > > > [ ] +1 approve
> > > > > > > >
> > > > > > > > [ ] +0 no opinion
> > > > > > > >
> > > > > > > > [ ] -1 disapprove (and reason why)
> > > > > > > >
> > > > > > > > Thanks
> > > > > > > >
> > > > > > >
> > > > > >
> > > > >
> > > > >
> > > > >
> > > > > --
> > > > > Jagadish V,
> > > > > Graduate Student,
> > > > > Department of Computer Science,
> > > > > Stanford University
> > > > >
> > > >
> > >
> >
> >
> >
> > --
> > Haifeng (Fred)  Ji
> >
>

Reply via email to