> -----Original Message----- > From: dev [mailto:dev-boun...@openvswitch.org] On Behalf Of Daniele Di > Proietto > Sent: Thursday, March 12, 2015 6:05 PM > To: dev@openvswitch.org > Subject: [ovs-dev] [PATCH 4/6] dpif-netdev: Allow controlling non PMD > threads' affinity > > This commit introduces the 'other_config:nonpmd-cpu-mask' key to control > the CPU affinity of non PMD threads. > > Signed-off-by: Daniele Di Proietto <diproiet...@vmware.com> > ---
[snip] > static char * > diff --git a/lib/dpif-provider.h b/lib/dpif-provider.h > index 7b4878eb..3612766 100644 > --- a/lib/dpif-provider.h > +++ b/lib/dpif-provider.h > @@ -309,9 +309,10 @@ struct dpif_class { > /* If 'dpif' creates its own I/O polling threads, refreshes poll threads > * configuration. 'n_rxqs' configures the number of rx_queues, which > * are distributed among threads. 'cmask' configures the cpu mask > - * for setting the polling threads' cpu affinity. */ > + * for setting the polling threads' cpu affinity. 'cmask_nonpmd' > + * configures the cpumask of the remaining OVS threads */ > int (*poll_threads_set)(struct dpif *dpif, unsigned int n_rxqs, > - const char *cmask); > + const char *cmask, const char *cmask_nonpmd); You should probably rename cmask to cmask_pmd similar to how you have made the names more specific elsewhere. _______________________________________________ dev mailing list dev@openvswitch.org http://openvswitch.org/mailman/listinfo/dev