Jarno Rajahalme (4):
  lib/odp-util: Only use expected_bit when set.
  dpif-netdev: Do not check mask if it doesn't exist.

v5:
 - Split dpif_netdev_flow_mask_from_nlattrs() to
   dpif_netdev_flow_from_nlattrs() and dpif_netdev_mask_from_nlattrs()
   and make the latter to require non-zero mask_key_len.
 - Make dp_netdev_flow_add() to initialize an exact match mask if no
   wildcards are given.  This reflects the kernel datapath behavior.

  lib/flow: Add IPv6 support for flow_compose().

v5:
- Set flow label and tclass directly, factor out transport layer
  code for both IPv4 and IPv6.

  Classifier: Track address prefixes.

v5:
- Refactoring and cleaning up based on Ben's comments.
- Ben's updated commentary on lib/classifier.h.
- Explain the prefix offset numbering used in comments.
- Get more of a prefix from the next word if necessary.
- Refactor to eliminate duplicated code.
- trie_remove(): Also prune parent nodes if possible.
- schema: Changed "fieldspec" smap to "prefixes" set.
- removed support for metadata field, as it has no datapath equivalent.
- Added NEWS.

 NEWS                       |   24 ++
 lib/classifier.c           |  675 ++++++++++++++++++++++++++++++++++++++++++--
 lib/classifier.h           |  152 ++++++++--
 lib/dpif-netdev.c          |   88 ++++--
 lib/flow.c                 |  144 +++++++---
 lib/meta-flow.c            |   56 ++++
 lib/meta-flow.h            |    3 +
 lib/odp-util.c             |    2 +-
 lib/ofp-util.h             |    2 +-
 ofproto/ofproto.c          |    6 +-
 ofproto/ofproto.h          |    8 +
 tests/classifier.at        |   47 +++
 tests/ofproto-dpif.at      |   35 ++-
 tests/test-classifier.c    |   17 +-
 vswitchd/bridge.c          |   40 ++-
 vswitchd/vswitch.ovsschema |    8 +-
 vswitchd/vswitch.xml       |   62 ++++
 17 files changed, 1249 insertions(+), 120 deletions(-)

-- 
1.7.10.4

_______________________________________________
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman/listinfo/dev

Reply via email to