The following patches were already reviewed by Jesse, and are
reposted with comments incorporated.

  ofproto-dpif: New function ofproto_receive().
  netdev: Rename get_drv_info() to get_status().

The following patch fixes a bug found by Jesse in review:

  netdev-vport: Fix theoretical null pointer dereference.

The following patches are required for flow based tunneling, but do
not necessarily need to be merged immediately.  I personally don't
feel strongly either way.

  netdev-vport: New helper netdev_get_vport_dev().
  vswitch: Remove PMTUD support from userspace.
  netdev-vport: Manage ethernet addresses in userspace.

Ethan Jackson (6):
  ofproto-dpif: New function ofproto_receive().
  netdev-vport: Fix theoretical null pointer dereference.
  netdev: Rename get_drv_info() to get_status().
  netdev-vport: New helper netdev_get_vport_dev().
  vswitch: Remove PMTUD support from userspace.
  netdev-vport: Manage ethernet addresses in userspace.

 NEWS                   |    1 +
 lib/netdev-bsd.c       |    4 +-
 lib/netdev-dummy.c     |    2 +-
 lib/netdev-linux.c     |   55 +++++++++------------
 lib/netdev-provider.h  |    8 +--
 lib/netdev-vport.c     |  115 +++++++++++++++----------------------------
 lib/netdev.c           |    6 +--
 lib/netdev.h           |    2 +-
 ofproto/ofproto-dpif.c |  128 +++++++++++++++++++++++-------------------------
 vswitchd/bridge.c      |    2 +-
 vswitchd/vswitch.xml   |   12 -----
 11 files changed, 136 insertions(+), 199 deletions(-)

-- 
1.7.9.5

_______________________________________________
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman/listinfo/dev

Reply via email to