> I believe that the following may be simplified to "dev->carrier =
> change->running":

Yes, I agree.  However, in a future patch of the series, I need to
update the carrier_resets sequence number in these if blocks.  If you
like I can change it in this patch, but the final code is going to end
up the same.

Ethan


>> +                if (dev->carrier != change->running) {
>> +                    dev->carrier = change->running;
>> +                }
>
> Same in netdev_linux_cache_cb().
>
> Otherwise this looks good to me.  Thank you.
>
_______________________________________________
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman/listinfo/dev

Reply via email to