I think the -packet option needs to be surrounded by square braces in the man page.
I may be misreading the man page, but I don't think it actually explains what the -packet option does. Should we document it at all? Perhaps it should be hidden since it's only useful for unit testing. If we decide to keep it, I would rename it "-p". I found the man page confusing because the option was named similarly to one of the arguments to the trace command. > + if (flow->dl_type == htons(FLOW_DL_TYPE_NONE)) { > + struct eth_header *eth = b->l2; > + eth->eth_type = htons(b->size); This seems like a strange choice of eth_type in this case. Is there any particular reason the size of the packet was chosen? Seems fine otherwise. Ethan _______________________________________________ dev mailing list dev@openvswitch.org http://openvswitch.org/mailman/listinfo/dev