[ 
https://issues.apache.org/jira/browse/HIVE-2188?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13043362#comment-13043362
 ] 

jirapos...@reviews.apache.org commented on HIVE-2188:
-----------------------------------------------------


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/831/#review753
-----------------------------------------------------------



trunk/metastore/if/hive_metastore.thrift
<https://reviews.apache.org/r/831/#comment1571>

    How about calling it get_multi_table instead? multi_get_table sounds little 
confusing to me.



trunk/metastore/src/java/org/apache/hadoop/hive/metastore/HiveMetaStore.java
<https://reviews.apache.org/r/831/#comment1572>

    You can write this more concisely using commons-lang utility method as: 
StringUtils.join(tbls,',');



trunk/metastore/src/java/org/apache/hadoop/hive/metastore/HiveMetaStore.java
<https://reviews.apache.org/r/831/#comment1576>

    You can get rid of tables.get(i) == null check that will never be true.



trunk/metastore/src/java/org/apache/hadoop/hive/metastore/HiveMetaStore.java
<https://reviews.apache.org/r/831/#comment1573>

    Instead of throwing RuntimeException, create MetaException and throw that.



trunk/metastore/src/java/org/apache/hadoop/hive/metastore/RawStore.java
<https://reviews.apache.org/r/831/#comment1574>

    Please add javadocs for new methods introduced in interface. Also see my 
first comment for name.



trunk/service/src/test/org/apache/hadoop/hive/service/TestHiveServer.java
<https://reviews.apache.org/r/831/#comment1575>

    This test really belongs in the TestMetastore or some such in metastore dir 
not in HiveServer.


- Ashutosh


On 2011-06-02 23:01:00, Sohan Jain wrote:
bq.  
bq.  -----------------------------------------------------------
bq.  This is an automatically generated e-mail. To reply, visit:
bq.  https://reviews.apache.org/r/831/
bq.  -----------------------------------------------------------
bq.  
bq.  (Updated 2011-06-02 23:01:00)
bq.  
bq.  
bq.  Review request for hive, Paul Yang and Ashutosh Chauhan.
bq.  
bq.  
bq.  Summary
bq.  -------
bq.  
bq.  Created a function "multi_get_table" that retrieves multiple tables on one 
trip to the hive metastore, saving round trip time.
bq.  
bq.  
bq.  This addresses bug HIVE-2188.
bq.      https://issues.apache.org/jira/browse/HIVE-2188
bq.  
bq.  
bq.  Diffs
bq.  -----
bq.  
bq.    trunk/metastore/if/hive_metastore.thrift 1130342 
bq.    
trunk/metastore/src/java/org/apache/hadoop/hive/metastore/HiveMetaStore.java 
1130342 
bq.    
trunk/metastore/src/java/org/apache/hadoop/hive/metastore/ObjectStore.java 
1130342 
bq.    trunk/metastore/src/java/org/apache/hadoop/hive/metastore/RawStore.java 
1130342 
bq.    
trunk/service/src/test/org/apache/hadoop/hive/service/TestHiveServer.java 
1130342 
bq.  
bq.  Diff: https://reviews.apache.org/r/831/diff
bq.  
bq.  
bq.  Testing
bq.  -------
bq.  
bq.  Added a test case to testMetasore() in TestHiveServer.  Also tested for 
speed improvements in a client session.
bq.  
bq.  
bq.  Thanks,
bq.  
bq.  Sohan
bq.  
bq.



> Add multi_get_table function in Hive Metastore
> ----------------------------------------------
>
>                 Key: HIVE-2188
>                 URL: https://issues.apache.org/jira/browse/HIVE-2188
>             Project: Hive
>          Issue Type: New Feature
>          Components: Metastore
>            Reporter: Sohan Jain
>            Assignee: Sohan Jain
>            Priority: Minor
>         Attachments: HIVE-2188.1.patch
>
>
> This function would get multiple tables from the hive metastore as opposed to 
> just one at a time, saving round trip time to the metastore.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

Reply via email to