[ 
https://issues.apache.org/jira/browse/HTTPCLIENT-2019?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16962022#comment-16962022
 ] 

Gary D. Gregory commented on HTTPCLIENT-2019:
---------------------------------------------

I find that in order to avoid confusion and potential issues, it is best to add 
scale to API names like "getRetryInterval", is it "getRetryIntervalSeconds" or 
"getRetryIntervalMillis"?

> Deprecate ServiceUnavailableRetryStrategy in favor or a more generic name
> -------------------------------------------------------------------------
>
>                 Key: HTTPCLIENT-2019
>                 URL: https://issues.apache.org/jira/browse/HTTPCLIENT-2019
>             Project: HttpComponents HttpClient
>          Issue Type: Improvement
>          Components: HttpClient (classic)
>    Affects Versions: 4.5.10, 5.0 Beta6
>            Reporter: Michael Osipov
>            Priority: Major
>              Labels: stuck, volunteers-wanted
>             Fix For: Stuck
>
>
> Based on a 
> [discussion|http://mail-archives.apache.org/mod_mbox/hc-dev/201910.mbox/%3Cff79e9739c5aa8639ee785e6848c9e5112113ee5.camel%40apache.org%3E]
>  on the mailing list, the name {{ServiceUnavailableRetryStrategy}} implies 
> that this interface is only suited for HTTP status code 503, but you make 
> handle any 3xx, 4xx, 5xx code. Therefore, this interface should be renamed to 
> something better/more generic like {{RetryStrategy}}.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscr...@hc.apache.org
For additional commands, e-mail: dev-h...@hc.apache.org

Reply via email to