On 9/18/15, 11:54 AM, "Josh Tynjala" <joshtynj...@gmail.com> wrote:
>Of the options that you presented, I think I like *.Event and .Event the >most. > >The options with :: don't feel quite right. While I know that packages are >namespaces (I remember making that discovery back in the day and excitedly >blogging about it), other classes aren't usually referenced with :: in >code. With that in mind, I like . better than :: because the . is more >consistent. If it were somehow easier to implement, though, I could live >with it. > >A simple string like global or null might conflict with some top-level >variable in user code or in the standard library of some JS environment, >so >I think that style should be avoided. Agreed. > >Of the two between *.Event and .Event, I'm not quite sure which I like >better. Which of these seems more readable? > >var myVar:.Event = new .Event(); > >var myVar:*.Event = new *.Event(); > >At first, I thought I liked *.Event better, but I might be preferring >.Event more now. Yeah, it might be easier grammar-wise to have something in front of the ‘.’. I’m still digging into the compiler. I will report my findings and recommendations before committing anything. -Alex