25/04/2018 07:33, Zhang, Qi Z: > > 10/04/2018 15:59, Thomas Monjalon: > > > > --- a/lib/librte_ether/rte_ethdev.h > > > > +++ b/lib/librte_ether/rte_ethdev.h > > > > +#define DEV_RUNTIME_RX_QUEUE_SETUP 0x00000001 /**< Deferred > > setup > > > > +rx queue */ #define DEV_RUNTIME_TX_QUEUE_SETUP 0x00000002 > > /**< > > > > +Deferred setup tx queue */ > > > > > > Please use RTE_ETH_ prefix. > > Actually I saw all the offload flag is started with DEV_, so > Should I still need rename to RTE_ETH_DEV_CAPA_***?
Yes The flags starting with DEV_ will be managed later because it is hard to rename an existing flag. It is in my roadmap. The idea is to not add new flags with wrong namespace prefix.